0 Favourites

Performance drop

  • Hey!

    Just wondering, has anyone else noticed a performance drop recently? I haven't worked on my project for a little over a month, but recently repositioned a lot of the layers, etc to ensure I was getting a smooth 60fps.

    I loaded it up today with version 146, and suddenly noticed it looked like it was lagging slightly. Ran the new debugger, and saw that the frame rate had effectively halved down to 30.

    No idea what could have caused this. Even levels which are pretty straight forward with not much happening are running at the same fps.

    In the debugger, the engine appears to be running the highest, sometimes reaching 7%, and the draw cells are occasionally the same.

    I can't see what needs to be changed. It's just slightly frustrating that I have to go through bit by bit again to find out what's causing this sudden drop.

  • Yeah, just tried it on another project I was working on this morning, and there is a massive drop by about half on that one too.

    Shame.

  • See, now I'm confused. I just downgraded C2 back to 145 and ran the project I was working on this morning at 60fps, and it's also half now. Any ideas on what could cause this sudden change, even on an older version?

    The only other thing I've done on this pc today is install Battlefield 4 beta, that that was on a separate hard-drive.

  • Turns out BF4 wasn't installed, just downloaded through Origin, so it wasn't that. However, I've just done a system restore, and it stated that a version of DirectX was installed. Could this be my problem maybe?

  • Hmm, well, if you had 60fps on 145, 30fps on 146, then downgraded back to 145 and get 30fps, then that would probably mean that's your computer and not C2 :P However, I have been noticing MY experience with running my C2 projects has been getting lower and lower FPS over time too, but I do a lot on my computer so I can safely bet it's that. Might wanna check your Task Manager and see whats up.

  • Just downloading C2 onto my laptop to see what I'm getting there. Really confusing, as the only thing that has changed was that BF4 dload... unless Steam's done some automatic updating...

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Hold on, that's quite weird; I'd done a system restore recently too and my performance has been lower since then. I'm gonna go update my drivers and whatnot, maybe you should too :P

  • I did a system restore to an earlier time, which was before a Critical Windows 7 update. It is now back up to 60fps!!!

    Very strange. I actually started to doubt my memories.

  • Using debugger can decrease fps, otherwise without debugger, it would stay stable fps.

  • This was visual at first, followed by a text box with an fps counter, followed up by the debugger.

    As I said, restoring fixed this, but I'm sure it'll be a problem again once I re-update windows.

  • Which browsers have you tested?

    V-syncing can make framerate jumps bigger than they actually are - at 60.1 FPS, it will successfully V-sync at 60 FPS, but at 59.9 FPS, it will keep missing a V-sync interval and can often jump right down to 30 FPS. The actual frame processing time only changed by 0.2 FPS though. So it could be a very small change. It's important to at least test Chrome, Firefox and IE though, to verify whether it's just one browser or consistent.

  • Ashley Just Chrome, but it's back to normal after I did a system restore to before a critical windows update, and a direct x update.

  • Performance dropped with Chrome update... 60 FPS to 30 FPS...

  • I test my game on every C2 and Chrome update.

  • Ulisses Check your system restore points. What was recently installed?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)