Pathfinding stops moving after using Persist?

  • Not really sure where to put this, perhaps it's a bug of some sort but I can't seem to reproduce it outside of my project so I'm wondering if anyone's ever had a run in with something similar.

    I have sprites that use Pathfinding and Persist, and after changing layout and coming back, they stop moving. However they don't register as actually stopped by the Pathfinding - after running some checks it seems they're meant to be moving, but for some reason are just stuck in place. Running events to make the sprites move along path will sometimes nudge them along a little at a time. I haven't been able to reproduce this in e.g. the RTS template so I'm not sure what's up. Any ideas what might be causing the hangup? A runaway loop maybe?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Excuse me for the guessing game.

    Are they maybe global ? Do you have the same amount of objects after and before returning to the layout ?

  • Ha, no worries it's pretty much a guessing game for me too at this point. I realized this would be hard to diagnose without seeing the .capx but it's a massive .capx so I didn't want to have people sifting through lots of unrelated code to try and find one problem.

    Anyway, yep, the amount of objects remains the same. I didn't realize it's possible to have a layout keep going after switching away from it, I figured it's automatically paused when that happens.

  • Works perfect in a simple version. So must you seek it in the events. Something that runs in the start up maybe ?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)