Laptop problems

  • Hi, this is my first game using Construct2, a simple little Breakout clone called Demobot, however when trying to play the game on a laptop a few assets such as the walls of the play area and the title in the opening and credits doesn't load and I cannot identify why as I am not too great with coding .

    Here is a link to my game for anyone who wants to play or wishes to see the issues listed to see if they can help:

    sincil.co.uk/files/kiddercollgames/demobot

    and for anyone who knows about coding I have already run this game on a laptop that cannot run the game through both Internet explorer and Google Chrome (I Recommend chrome personally) and I have made a copy of the code found by going to the developer's tools (or equivalent in chrome's case) along with pictures in the following link to a word documentation:

    1drv.ms/w/s!AhZ0UsrDRDqAgyUKK0txP_-aoOMw

    Thank you very much for your time.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • MegaAntMan1

    I tried and played to level 3. The game finished loading without any error or getting stuck - so that tells me the assets must have loaded.

    these are the errors I get in the console when the game starts: (sounds like there is a problem where you set the size of the objects - and it is coming out non-numeric or something...)

    WebGL: INVALID_VALUE: texImage2D: width or height out of range

    GLWrap_.loadTexture c2runtime.js:3231

    (index):111 Failed to register service worker: DOMException: Only secure origins are allowed (see: https://goo.gl/Y0ZkNV).

    OnRegisterSWError (index):111

    117(index):1 [.Offscreen-For-WebGL-000001FB7FD0B350]RENDER WARNING: texture bound to texture unit 0 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering.

    2c2runtime.js:3231 WebGL: INVALID_VALUE: texImage2D: width or height out of range

    GLWrap_.loadTexture c2runtime.js:3231

    4(index):1 [.Offscreen-For-WebGL-000001FB7FD0B350]RENDER WARNING: texture bound to texture unit 0 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering.

    WebGL: INVALID_VALUE: texImage2D: width or height out of range

    130(index):1 [.Offscreen-For-WebGL-000001FB7FD0B350]RENDER WARNING: texture bound to texture unit 0 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering.

    (index):1 WebGL: too many errors, no more errors will be reported to the console for this context.

  • Maybe you can contact you laptop seller to solve the problem

  • Hi, this is my first game using Construct2, a simple little Breakout clone called Demobot, however when trying to play the game on a laptop a few assets such as the walls of the play area and the title in the opening and credits doesn't load and I cannot identify why as I am not too great with coding .

    Here is a link to my game for anyone who wants to play or wishes to see the issues listed to see if they can help:

    http://sincil.co.uk/files/kiddercollgames/demobot/

    and for anyone who knows about coding I have already run this game on a laptop that cannot run the game through both Internet explorer and Google Chrome (I Recommend chrome personally) and I have made a copy of the code found by going to the developer's tools (or equivalent in chrome's case) along with pictures in the following link to a word documentation:

    https://1drv.ms/w/s!AhZ0UsrDRDqAgyUKK0txP_-aoOMw

    Thank you very much for your time.

    Hey, looks like I've got the same issue. On one of the PC's that I test my game on (on the oldest one) the background of one particular level goes completely black. It's WebGL's fault but I don't know how to solve this issue too. I started a topic on this question too, so here's the link, just in case: nwjs-level-goes-black-webgl-not-working-properly_t198463

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)