impossible in iphone

  • I can not put even 10 items that I try on my iphone and I have 30 fps and much lag ...

    I tried to make many different games and everyone I have half start because the taste and is fatal ...

    This program is not for iphone is for flash games ... that roamed I have.

  • Is this in browser or as an app?

  • I do not understand what you mean ... but I try it on my iphone and go-awful ... if I can not be 9 without physical objects, the program is worthless

  • he is asking are you running it in safari or cocoonjs or anything else because that effects performance

  • Trying running it in CocoonJS.

    Remember to disable WebGL to get better results for iPhone.

  • Anyway, still malfunctions ... if someone wants I can pass my game.

    I test it with latest version of CocoonJS in iphone 4 ios 5

  • HELPPPPPPPPPPP

  • I think what you encounter is normal. Disappointing, for sure, but normal. Mobile devices are not nearly as powerful as desktop, especially when it comes to HTML5, it's that simple. If latest generation devices like iphone 5 or ipad 2 can run games in HD resolution with decent frame rate, you can't say the same for older hardware (2 years is considered "old" for mobile devices).

    Why do you think the old school pixelated look got so popular lately? it's not just an artistic trend, it's just a lot easier to render 32*32 sprites than HD graphics on phones.

    So I guess there is nothing wrong with your export. You just need to optimize your game. I think it's the price to pay for using HTML5: it's portable, but not as efficient as coding native apps.

  • statham

    There are a lot of guidlines for mobile performance. Share your capx and then people can take a look.

  • This garbage game I made 5 sprites works for me 30 fps and every time I throw a bomb slows down and gets me up to 5 fps... tested in this iphone 4 to how much you will you?

    dropbox.com/s/cflspxgo0hsesjl/bb.capx

  • Right now, you have the screen being filled by the gpu about 2.5 to 3 times on each frame : on the layer tab, you have to make the background transparent in order for the gpu to "ignore" it.

    Next, your collision objects are very complex and being checked all the time. This is very heavy on performance, regardless of the engine you are using.

    Instead, you may want to :

    1- have your sprites not collide and build invisible rectangles for collisions

    2- only check for collisions when your character is overlapping or is close to a collider.

    Try to launch your game with the "debug layout" button to see how many times collisions are checked per frame. When you launch a bomb, the collision checks are multiplied, that's the reason why you get such low performances.

    Good luck,

    Nathan

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Well my iPod touch 4g which isn't as good as your phone. but seems to be along the same family line.

    I turned on WebGL

    You used a TileBackground, but those should always be power of 2(1,2,8,16,32,64,128,256,512,1023,2048) and not any other. So I changed that to 256. However since your background is only of 1 colour. I made the layout BG colour to that of the image colour. I turned off clear background. Also I'm not 100% sure on this. but I don't believe CocoonJS supports TiledBackground very well and using that will cause slow down.

    You On Touch and Every 1 second is improper. and I fixed that up too.

    Prior the game ran at 30fps.

    Before changes and WebGL turned on ran at 60fps

    After changes

    For me the game runs at 60fps.

    The explosion animation kills performance. And here is why.

    There are a total of 6 frames in your animation. However your forcing an animation rate of 15/19(bullet1/2) was too high. What is happening is that C2 is trying to cycle through the animations faster than you have animations. So this is causing your animation to get into very large loops which is causing a massive performance hit. This really shouldn't happen at all. But it is being wierd. For some reason a speed rate higher than your frames seems to create a minor slow down. wierd.

    I toned this down to just 3 fps for a test and the speed ran fine. Of course you want the explosion to be more than 3fps. So do was you need. But be careful not make it to high.

  • Valerien

    The collision is not the problem. The app only has 3 objects to collide with. Though he should use bounding box. It's still not the problem.

    Also it's not creating multiple bombs. The Event is OnTouchStart. So even with the 1.0 second every time there is no effect.

  • This is weird. Animating the explosion slower produces better performance. But that shouldn't happen at all. I wonder if there it this has to do with the explosion images. I take a look at them at let you know if I find what is peculiar.

  • eh. I can't seem to figure out 100% why there is a performance drop on the explosion. But here is the capx running most of the time at 55+fps

    drive.google.com/file/d/0B0V2EvCXNzYUQWRuckViYTJGLU0/edit

    maybe some one else would understand what is happening. I know when the Animatino speed was closer to 15+ the FPS would drop to 30 and even 15. But now only 35-45. But it's still odd. Good luck.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)