0 Favourites

IAP PhoneGap com.mcm.plugins.androidinappbilling

  • I have what I think is a basic implementation of the built in IAP object. I do a basic export without the intel checkbox checked. Zip it up and import it into Phonegap. Yet with just that I get the following errors. Does this not work anymore? Did I waste all those hours and the cost of the program on an unsupported and out of date development environment? None of the posts I have read are very positive. Please advise on what I can do.

    IOS and Windows:

    Error - The following plugin, plugin version or a dependancy of this plugin is not on npm: com.mcm.plugins.androidinappbilling

    Android:

    Error - One of your plugins requires a parameter: BILLING_KEY ...

  • You can find this number in your Google developer page. Look for tutorials on building Android APK.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • A part of the solution seems to be:

    remove the ..com...plugin.AndroidInAppBilling... line from the config.xml file and replace it with the following line:

    <plugin spec="https://github.com/poiuytrez/AndroidInAppBilling.git" />

    This allowed me to create an ipa file for ios with PhoneGap. I don't know if this has any unintended consequences yet, but it has allowed me to progress beyond the error.

    MPPlantOfficial - thanks for your advice. I am tackling Android next.

  • Hi, I've solved this issue for Android:

    In the config.xml remove this line:

    <plugin name="com.mcm.plugins.androidinappbilling">

    ...Instead add this:

    <plugin name="cc.fovea.cordova.purchase" spec="~7.1.0">

    <variable name="BILLING_KEY" value="YOURBILLINGKEYHERE" />

    </plugin>

    ...you don't need to bundle that plugin with your zip file for Phonegap Build as it already uses it. The problem seemed to be that Phonegap Build no longer supports the com.mcm.plugins.androidinappbilling plugin.

  • Thanks Jtibbles that worked!

    Note: adding <plugin spec="https://github.com/poiuytrez/AndroidInAppBilling.git" /> was a bad thing to do with Android.. it also triggered a need for the "BILLING_KEY". Using your sample code and not adding this plugin is what worked for me.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)