0 Favourites

How fix this bug?

  • This is important to fix?

    When i start preview

    "---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Could not find behavior's combo property index

    Condition: index >= 0

    File: Projects\BehaviorInstance.cpp

    Line: 374

    Function: class cr::pod<class std::vector<struct era::InstanceProperty,class std::allocator<struct era::InstanceProperty> > > __cdecl BehaviorInstanceERACallback::GetProperties(void) const

    Build: release 236 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Przerwij Ponów próbe Ignoruj

    ---------------------------

    "

  • Try removing any third party plugins, or checking any you have are up-to-date.

  • Try removing any third party plugins, or checking any you have are up-to-date.

    i have only 'touch, bullet, anchor, mouse, dragdrop'

    this is Orignal C2 plugins only in my project

  • Does this happen with every project?

    Does it happen with the built-in templates / examples?

    Is it possible to share the project for us to test?

  • Does this happen with every project?

    Does it happen with the built-in templates / examples?

    Is it possible to share the project for us to test?

    sure take look

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • IGDev

    I'm currently using the latest beta r236 and I has absolutely no issues running and previewing your project.

    The error you are getting is definitely a dodgy plugin/behavior somewhere on your system that is conflicting.

    It may be worth uninstalling C2, deleting (or just move if you want to keep) the remaining C2 folder from Program Files (also remove files from %appdata%\Construct2\).

    Then reinstall C2 and test.

    I know it's a bit of a bind, but it might be for the best.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)