0 Favourites

Game doesn't want to load

  • Are there other reasons than missing file / bad 3rd party plugin that would cause an exported HTML5 file not to load?

    I'm getting the following error in the Chrome console:

    Application Cache Error event: Resource fetch failed (-1)

    Uncaught Error: SecurityError: DOM Exception 18

    But for a different file every time I hit refresh (clicking on the link will load whichever file is claimed to be missing without any problems)

    I'm in the Dropbox public folder, previous HTML5 exported versions have worked fine, pretty sure all the files are uploaded, and the preview for this capx works.

  • If you're hosting on Dropbox, either you didn't upload all the files, or didn't make them all public.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Ok, I don't think this is true. Attaching a sample capx that has the same problem. It's in my public folder, the folder shows fully uploaded (green checkmark), and clicking on the link in the console error loads the file on my browser no problem. It's also suspect that a different file is generating the error every time I refresh.

    Sample capx

    db.tt/osZpTsJf

    Sample html

    db.tt/TmFn9yi4

    Edit: Spelling

  • So after spamming refresh a lot and watching the console (since it was erroring on a different file every time, I assumed it was caching them or something), the game does eventually load.

    Is this a case of Dropbox showing something is uploaded before it is or is there something else wrong? (note it was still not loading ~1 hour after exporting to my public folder)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread sticky
763 305,708
asikanddestroy's avatar
asikanddestroy
Unread hot topic
232 177,685
Tetriser's avatar
Tetriser
Unread hot topic
167 31,110
Ashley's avatar
Ashley Construct Team Founder