0 Favourites

Flappy Bird template - laggy and choppy on high end machine

  • Hi,

    I am a new user, just registered and downloaded Construct 2 for the first time.

    Ive opened the Flappy Bird template, as it came with the package and clicked on run layout.

    Now straight away the game is choppy and laggy with the settings that came straight out of the box.

    My machine is a high end workstation with 16GB of RAM, 64 bit Windows 7, up to date drivers for Nvidia 960GTX and multi-threaded processors.

    I am running Firefox and have plenty of room on my hard drive.

    Any ideas to what might be causing the lag? Can other users run the Flappy Bird template smoothly? I will try to go offline and try to run the template after a computer restart and after disabling the antivirus software. Other than that I don't have to many ideas on what might be causing the issue.

    I would be grateful for any insights.

  • Ok, Im back.

    Restarting and turning the antivirus off did not help anything.

    The choppiness isn't constant, it comes and goes. It looks like an oldschool tape refreshing issue on the screen, sort of a "rewinding" effect, and sometimes it slows down as well during.

    Does anyone here have a GTX 960 to confirm that its not an issue with the graphics card?

    I feel a bit bummed out at the moment, hopefully I can get past this issue.

    ---------------------------------------------------------------------------------------------------------------------------------------------------

    EDIT:

    The same thing happens with other templates

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Solomon

    Hi,

    I am a new user, just registered and downloaded Stencyl for the first time

    Wrong software.

    I have the GTX 970 and the 'Flapping Bird' template runs fine.

    Try it on a different browser.

    Try disabling all Firefox addons.

  • Solomon

    > Hi,

    > I am a new user, just registered and downloaded Stencyl for the first time

    >

    Wrong software.

    I have the GTX 970 and the 'Flapping Bird' template runs fine.

    Try it on a different browser.

    Try disabling all Firefox addons.

    Eh, yeah long day/week during which I was/am testing out different programs, sorry for the typo should not have happened

    I fixed my post, and my apologies once again.

    Well sure it might work with GTX 970, that is why I was asking specifically about someone with the same card and drivers as I have. Will check other browsers now, thanks for the reply.

  • If you are experiencing such performance with all the templates, then something is definitely amiss with your system, regardless of what GPU you have.

    The majority of the templates should have a negligible impact on most systems.

    Is it the latest stable release - r212.2 - that you are using?

  • I have just installed the software, my first post was just a couple minutes after.

    My Construct 2 version is: Release 212.2 (64-bit)

    The same problem appears in Opera, a "rewinding" line appears from time to time and there is choppy gameplay.

    My screen resolution is 1920x1200. Same thing happens when in full screen as in windowed mode.

    All in all my system is a few months after formatting and a fresh reinstall.

    Any other ideas to what the source of the problem might be?

  • I have disabled "hardware acceleration" in Firefox browser settings, and that fixed the scrolling artifact issues, but still there is some lag from time to time.

    So there is a partial victory here.

    Will try to dig up some more information regarding this, hopefully someone else had similar problems which they've solved.

    Cheers

  • Just checking. Did you use the latest driver from nvidia ? 355.60?

    Firefox 40 will disable hardware acceleration for anything older than 355.60.

    Also update firefox to latest version. I think it is 40.0.2 or something

  • Hi Tumira, yep I have the latest drivers I double checked that. Firefox is also the newest of versions.

    It seem that the issue has to do with the Windows live update. Ive turned it off some weeks ago but unfortunately it managed to download some updates, and as I did some reading on the internet there are loads of people that have issues with their system being slow simply because the updates made it slow.

    Will have to make a new fresh Windows install and turn of the updates immediately during the first launch. Lesson learned.

    Don't exactly know when I will be doing that but I will let you all know how it went and whether or not it solved the darn laggy problem.

  • I develop on a GTX 660 and have never seen such issues. Is it the same across Chrome, Firefox and IE/Edge? If Chrome is affected what does chrome://gpu say?

  • Hi Ashley, Ive only tested it out in Firefox and Opera, did not install Chrome.

    I think it has something to do with one of the Windows updates, been reading on other webpages concerning Html5 game development and I have found some posts where people mention similar issues due to updating Windows.

    I will keep you all informed how it goes.

  • Solomon

    I had a similar experience recently after a Windows Update.

    Microsoft decided I needed an 'Important' update (KB3035583), which after installing, placed an annoying 'Get Windows 10' icon in the notification tray, as well as resetting Automatic Updates to include the Recommended updates (which, after 15 years of updating my company systems I know are pointless). This had the unfortunate effect that when going to shutdown for the night, I found I had 58 updates to install.

    After install, my system was a dog. Luckily, I know what I'm doing and managed to get it back to it's previous state.

    TL;DR

    Don't trust Micrs**t ;/

    It is certainly possible an update has caused your system to be 'glitchy'.

  • Solomon

    I had a similar experience recently after a Windows Update.

    Microsoft decided I needed an 'Important' update (KB3035583), which after installing, placed an annoying 'Get Windows 10' icon in the notification tray, as well as resetting Automatic Updates to include the Recommended updates (which, after 15 years of updating my company systems I know are pointless). This had the unfortunate effect that when going to shutdown for the night, I found I had 58 updates to install.

    After install, my system was a dog. Luckily, I know what I'm doing and managed to get it back to it's previous state.

    TL;DR

    Don't trust Micrs**t ;/

    It is certainly possible an update has caused your system to be 'glitchy'.

    Ive tried to uninstall some updates, but there are just too many installed! For the moment I have to roll with my laggy system unfortunately because of work that I have to do, but Ill format my computer as soon as I find a window to do so.

    Yep I am almost certain now its because of the updates.

  • A little update on the lag issue. I have installed a new version of Windows 7 64 bit, with no updates, and still I have a lag in the Flappy Bird template.

    I managed to make a mockup of my game during the past week and it too lags sometimes.

    This saddens me quite a bit, as I dont know what might be the problem this time around, it was not the Windows updates as I thought.

    Any other ideas would be welcome.

  • Hi Solomon,

    A couple questions...

    Have you tried the template on a different computer, or even a phone?

    Is there lag on any C2 games that other people have made?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
152 19,231
Magistross's avatar
Magistross
Unread hot topic
45 6,074
AndreasR's avatar
AndreasR
Unread hot topic
88 18,483
anhduc3108's avatar
anhduc3108