Debug Previews crashing/closing on start?

  • I have been noticing this behavior for a while but I don't know that it's necessarily a bug, but maybe intended in some way. The project in question is several hundred MB and is preparing to be commercially released.

    Ehat happens is that when the project is loading in the preview window (whether it's in debug mode or normal), there's a good chance (40-50%) that when it is fully loaded (when the blue loading bar hits 100%), the preview window will silently and instantly close itself as if I had ALT+F4'd it. No error messages, no indication of why, and then it's as if I had never pressed the preview button (I can do it again from the editor and it usually works a 2nd time). It seems to happen more often when I already have a preview window open and attempt to preview the project again (continuous preview has never worked for me). It has even occurred when using the "restart" button inside the debugger tools menu.

    The only code in the game capable of quitting the project like this is set to wait for a specific function using a specific parameter that can only be called by the player clicking a button, so I don't think that code has anything to do with this strange behavior.

    My previews are run in NW.js, and I have noticed this happening regardless of the version of C2 or NW.js that I'm using.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)