0 Favourites

Control in Browser Problem...

  • Hi.

    I have a problem with game control.

    There is strange things happen depending on browser.

    Generally in Chrome and as a standalone game it works fine.

    But for example on Edge Browser it is impassible to play.

    The player does not react as it should...

    The same problem concern my games,

    and games that i play on scirra.com.

    Please help

  • You haven't actually stated what the problem is you are having.

    If possible, give a link to or provide a .capx that you have these problems with and give instructions on what to look out for.

  • I have Windows 10 Pro, and the problem concern the keyboard.

    Sorry i did not write this in my previous post...

    The problem is taht the player sometime does not want to go, or sometime he does not want to stop.

    When i using the bug layout i figure it out that the problem is vector x, and vector y on platform.

    Thanx

  • I am not sure what do you mean zenox98.

    If you want to see my game the link is:

    riven.net.pl/blox-factor

    I have this problem even i use the platformer template.

    The player is out of control,

    and i think the problems are vectors (x and y)

    But for example in Chrome it works good...

    I include a picture that shows what vectors i mean.

    These vectors often are not reset when they should...

    I am not proficient in English - i hope i write about my problem quite well.

  • zenox98

    It is true. Also on my laptop. The platformer template is barely playable in Edge. Perfect in Chrome.

    It happens after two arrow keys are pressed (even briefly) at the same time. Right after that, the character does not respond, or just keeps running.

  • I still use Win 7 Pro and mainly Firefox so I doubt this would affect me then.

    Maybe if a simple bug report could be submitted, Ashley could shed light on this or come up with a work-around.

    AFAIK he uses win 10 and Edge also so may have experienced this already.

  • Hehe, i dislike Edge, very much.

  • Yes, I'm having the exact same problem with Edge: Whether I use default control for the 8-direction behavior or "simulated 8-direction" control, my sprite will stand still for a moment, then move and not stop when I release the mouse button. Also, its animated movements continue for a few seconds before shutting off, even if I use a variable to toggle it off or deactivate the Group that its Events are a part of. In Firefox and Chrome it works fine.....

    I just remembered that there's a Scirra blog post about Edge, I think. I'll read it now to see if anything about this is mentioned there.

    Forgot to mention that I'm also using Windows 10.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I haven't found much online about this problem, but it's mentioned here in the "Fixed Bug" section as a problem with the Edge browser and that it should be reported directly to Microsoft. One or two people reported it to MS, but nothing's been resolved, as far as I can see. I was wondering if anyone else here has been having this problem and if they found a workaround? Probably just have to wait for MS to resolve it....

  • Thanx terransage, and others.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)