cocoon io error

  • config i copy and paste in cocoon

    <gap:plugin name="org.crosswalk.engine" source="pgb" />

    <gap:plugin name="cordova-plugin-whitelist" source="npm" />

    <access origin="*" />

    <gap:plugin name="https://github.com/appodeal/Appodeal-PhoneGap-plugin.git" source="npm" />

    <gap:plugin name="https://github.com/appodeal/PhoneGap-GooglePlayServices.git" source="npm" />

    <gap:plugin name="org.apache.cordova.inappbrowser" source="npm" />

    yes i change the 5 gap:plugin to cocoon:plugin

    i think this line is giving the error

    <gap:plugin name="org.crosswalk.engine" source="pgb" />

    i get this email error

    Faulty compiled platforms

    android

    Fetching plugin "org.crosswalk.engine@" via cordova plugins registry

    npm http GET http://registry.cordova.io/org.crosswalk.engine

    npm http 404 http://registry.cordova.io/org.crosswalk.engine

    Fetching from cordova plugins registry failed: 404 Not Found: org.crosswalk.engine

    Fetching plugin "org.crosswalk.engine@" via npm

    npm http GET https://registry.npmjs.org/org.crosswalk.engine

    npm http 404 https://registry.npmjs.org/org.crosswalk.engine

    TypeError: Cannot read property 'latest' of undefined

    at next (opt/sdks/cordova-5.0.0/node_modules/cordova-lib/node_modules/npm/lib/cache.js:667:35)

    at opt/sdks/cordova-5.0.0/node_modules/cordova-lib/node_modules/npm/lib/cache.js:695:5

    at saved (opt/sdks/cordova-5.0.0/node_modules/cordova-lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:162:7)

    at opt/sdks/cordova-5.0.0/node_modules/cordova-lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:123:7

    at Object.oncomplete (fs.js:108:15)

  • It is recommended that the compiler be upgraded. error also

  • wizdigitech

    shatter-box.com/knowledgebase/cocoonio-how-to-build-a-game-using-construct-2/

    Delete <gap:plugin name="org.crosswalk.engine" source="pgb" />, you're using canvas and no crosswalk.

  • i give up i am getting too many error and yes Matheus.... i delete the line and get error

    i also a very very long email with error

    this is just 5% of the email

    It is recommended that the compiler be upgraded.

    warning: java/util/Locale.class(java/util:Locale.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    It is recommended that the compiler be upgraded.

    warning: android/os/Bundle.class(android/os:Bundle.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    It is recommended that the compiler be upgraded.

    warning: android/content/ContentResolver.class(android/content:ContentResolver.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    It is recommended that the compiler be upgraded.

  • wizdigitech, I had the same issue as you did. The thing is that instructions is for a different type of exporter I think. This is what I did which resolved it, with the help of some of the experts. Export it to Cordova. No need to copy any of the codes, just delete the two xml files in the exported folder. Now while inside that folder itself, select all the files and create a zip file. Next upload that zip file to cocoon. Than inside there, just do all the normal settings, but this time, leave the config xml section alone. No need to do anything for that part, just do all your normal settings and than export. It should now work just fine.

  • i give up i am getting too many error and yes Matheus.... i delete the line and get error

    i also a very very long email with error

    this is just 5% of the email

    It is recommended that the compiler be upgraded.

    warning: java/util/Locale.class(java/util:Locale.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    It is recommended that the compiler be upgraded.

    warning: android/os/Bundle.class(android/os:Bundle.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    It is recommended that the compiler be upgraded.

    warning: android/content/ContentResolver.class(android/content:ContentResolver.class): major version 51 is newer than 50, the highest major version supported by this compiler.

    It is recommended that the compiler be upgraded.

    you are exporting in Cordova in the construct?

  • yes i am exporting using cordova in C2

    I AM 90% ON COMPLETING MY SECOND GAME

  • Hi,

    please post all cocoon.io related issues on the cocoon forum over here: https://forums.cocoon.io/

    I will have a look at your matter then.

    Thanks!

    Regards

    Andy

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • AndreasR of because i been trying to use it both of my game and it always fail

  • AndreasR of because i been trying to use it both of my game and it always fail

    Hi wizdigitech,

    please open a new post in the cocoon.io forum, which I linked below.

    https://forums.cocoon.io/t/construct-2- ... blems/1076

    Fill out the issue report and send it back to me.

    Regards

    Andy

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)