0 Favourites

Bug between Constuct 2 and node webkit ?

  • Hello everyone,

    I've a got a weird problem with the node webkit export. I'm going to try to explain :

    I have an object "car" active with a bullet behavior. These cars, move to the left at a speed of 200 at start. The angle is set and the speed is set with a variable at the start of the layout. When a collision happens, I stop these cars (speed = 0 , stop the bullet movement etc...) , and a few second later theses cars start to move again at a higher speed (speed = speed +50).

    This, works correctly when I export the project in html 5 BUT, if I export it with node webkit , when cars start moving again after the "pause", they move backward...(to the right instead of to the left).

    This does not happen in html 5, only with node webkit. I try to set up the angle of motion etc... but nothing, same problem. Any idea ?

    It seems that if I play with the "enable / disable" bullet behavior option, I don't have this problem. That occurs only if I stop the cars with the set speed option of the behavior (set speed = 0) and only if you export (it seems that preview doesn't affect it).

    Thank you in advance,

    PS : (sorry for my english...)

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • nobody ?

  • You're not describing anything that would be directly related to the different types of export, so you will need to provide more info.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)