0 Favourites

Blurry layout editor?

  • Forgive me if this has been covered already, but I have a kind of annoying problem that I haven't been able to work out. Basically, all the sprites in my layout editor appear super blurry.

    <img src="http://s27.postimg.org/8wd4gd35v/Blurry_Editor.png" border="0" />

    This is at 1:1 scale, for the record.

    I'm not sure what causes this or how to fix it - the sprites appear just fine at runtime, as well as in the image editor, but in the layout editor, they all appear blurred out like this.

    Is there some way of fixing this, or is this a weird problem specific to my setup somehow?

  • Have you tried updating your graphics card driver?

  • Hear that?

    Silence...

    Either way, may i ask what's the sampling setting for the project in question? Also, what resolution are the sprites in? Are the resized, by any chance?

  • Any attempts to update my graphics driver tell me that they're up to date already; I just tried again to no avail. I believe they're up to date.

    The project uses point sampling, with sprites at the "pixel art" level of size (the main character is between 32 and 64 pixels tall). The project resolution is 640 by 360. The sprites are displayed at their native resolution and are not resized.

  • Let me ask you. this happen too when you create a new project or just the one you are working on? Maybe you have apply a Blur effects on the layout?

  • It looks like you are using sprites a few pixels in size and scaling them up to be big rectangles. The editor has always done that when stretching that much.

    It doesn't hurt anything it's only in the editor.

    I used to scale a single pixel up to color the background before we had that option, and you could barely even see it, it blurred so much. If you need to have more clarity in the editor, use bigger sprites.

  • Let me ask you. this happen too when you create a new project or just the one you are working on? Maybe you have apply a Blur effects on the layout?

    This happens on all of my projects. There are no effects on the layout at all, otherwise I'd see them at runtime.

    It looks like you are using sprites a few pixels in size and scaling them up to be big rectangles. The editor has always done that when stretching that much.

    It doesn't hurt anything it's only in the editor.

    I used to scale a single pixel up to color the background before we had that option, and you could barely even see it, it blurred so much. If you need to have more clarity in the editor, use bigger sprites.

    Like I said before, these sprites are displayed at the correct size; they're just blurry. None of the sprites are scaled up.

    <img src="http://s17.postimg.org/bn0sv4kan/Blurry_Editor2.png" border="0" />

  • Ooh, that is weird. (I had thought you meant the image was not edited for size.)

    <img src="https://dl.dropboxusercontent.com/u/85412219/forumposts/EditorBlur.png" border="0" />

    It still looks like it's reducing to 3 by 6, and then scaling back up.

  • If details on my system help, I'm using integrated Intel HD 3000 graphics on a laptop running Windows 8.1.

  • It still looks very likely like a driver bug. Post a .capx and we can probably verify it displays correctly for everyone else. If that's the case, you'll need to contact Intel about the problem.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Are you sure you are previewing the project at 100% scale?

  • I've tried just about everything to get it to display correctly.

    I'm just going to deal with it for now; with any luck, it won't be too long before I'm able to get a more recent system to develop on. It hasn't been a problem so far (other than being kind of irritating) - if this isn't an easy fix and nobody else is having the problem, I'm not sure how much there is to be done!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)