Admob and Browser object not working in latest XDK update

  • Thanks for your reply, I will retry to get interstitials working.

  • I saw a Kyatric's "AdMob working on Android-Crosswalk" tutorial. It's really nice and very detailed, but I think all the CLI5.1.1 version is in some point problematic for C2, at least for me. The plugin setting is buggy, if I use default plugin setting, I get the error on Build (uploading project step), but if I remove them and then add them again (or not), the build work correct... And the major problem is the same HTML projects run extremely slow, when they runs smoothly on CLI 4 ///14

  • [SOLVED] Regarding the BROWSER OBJECT not opening external URLs:

    whitelist the URL OR use "*" to whitelist all traffic!

    I used W3C widget whitelist and I put * in both internal and external Whitelist.

    It helped me, now the "Open link in new window" works fine

  • Does anyone have a solution about the admob issue in the cli 5.1? I don't want to downgrade it.

  • saf

    Thanks, i was having issues with the Brower object not opening URLs, your solution worked for me

  • https://www.scirra.com/forum/i-have-some-problem-about-export-my-game-on-android_t163200 My problem like a this issue.Please help me for these INTEL XDK settings.

  • Same problem here.. : -(

  • Problem over here too. The browser is partially working, alerts and close game for example work fine. But if I try to go to an url, that doesn't work. Having some weird issues with the ads too, the banner doesn't appear until after the first interstitial displays, even though it's supposed to appear way before that. After a interstitial appears, it seems to work fine....

    Whatever, too many issues, too many headackes, I give up... I'll just release my game like this and what will be will be....

    Have you tried whitelisting the URLs you are trying to reach?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • No, I haven't tried that yet saf . I'll try it when I get closer to releasing my next game. Thanks for the advice.

  • [SOLVED] Regarding the BROWSER OBJECT not opening external URLs:

    whitelist the URL OR use "*" to whitelist all traffic!

    I used W3C widget whitelist and I put * in both internal and external Whitelist.

    It helped me, now the "Open link in new window" works fine

    Thank you my friend! Show your solution !

  • Problem over here too. The browser is partially working, alerts and close game for example work fine. But if I try to go to an url, that doesn't work. Having some weird issues with the ads too, the banner doesn't appear until after the first interstitial displays, even though it's supposed to appear way before that. After a interstitial appears, it seems to work fine....

    Whatever, too many issues, too many headackes, I give up... I'll just release my game like this and what will be will be....

    Did you whitelist the URL's you're trying to reach?

  • No saf I didn't, because the only links I tried to use(if memory servers) where for other games that I had published on googleplay. I'm getting pretty close to the testing phase of my next game, should I try to whitelist all url's no matter what they are?

    But even so, it still doesn't make sense, the twitter and facebook plugins worked fine, launched the proper windows, and you could tweet, etc. If whitelisting in intelxdk was the problem then wouldn't those plugins have been affected too?

  • I am having similar difficulties with my apps, many Problems since last Update.. Fullscreen ads and browser still not working....

  • But even so, it still doesn't make sense, the twitter and facebook plugins worked fine, launched the proper windows, and you could tweet, etc. If whitelisting in intelxdk was the problem then wouldn't those plugins have been affected too?

    Not sure, it could be that the plugins whitelist necessary domains by default? I remember having issues reaching external site from my game, and whitelisting helped.

  • Hm, ok guees I'll try whitelisting and see what happens. I'll be back with the results after the building and testing is finished.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)