0 Favourites

Won't Play Again

  • This started happening again everytime i click play

    dl.dropbox.com/u/75406771/konngam.capx

    <img src="http://i792.photobucket.com/albums/yy202/ph33t/fail-1.jpg" border="0" />

  • happening again? it was doing this before as well?

  • Here's the important part :

    --------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    GetSingleGlobalInstance(): is not exactly one instance

    Condition: insts.size() == 1

    File: Projects\ObjectClass.cpp

    Line: 572

    Function: class era::IObjectInstance *__cdecl ObjectTypeERACallback::GetSingleGlobalInstance(void) const

    Build: release 92 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    No matter if I click ignore or abandon, I also get a "C2 has stopped working" dialog.

    @t33p : How to report bugs

    Can you tell what were the last things you did in your project before getting the check failure on preview ?

    Edit: Moved to the "Bugs" forum.

  • Please see my post from your last thread. You never replied to it. Can you remember what causes this?

    t33hp: the 'Keyboard' object in your project became corrupt. I've recovered the project and it works now:

    dl.dropbox.com/u/15217362/officialgame-recovered.capx

    Obviously we want to prevent this ever happening again. Can you remember what you were doing just before the problem started? Did you do anything with the Keyboard object in particular?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • No, I didn't know what happened to both of them.

  • try re-install...

  • Here's a recovered project again:

    http://dl.dropbox.com/u/15217362/konngam-recovered.capx

    Last time, the Keyboard object became corrupt.

    This time, the Mouse object became corrupt.

    I really want to fix this problem so it never happens again, but I cannot find what the problem is without steps to reproduce the problem! Anything you can remember you were doing before the problem happened would be useful...

  • Are you mixing several projects in the same folder (saving as folder) ?

  • Here's a recovered project again:

    http://dl.dropbox.com/u/15217362/konngam-recovered.capx

    Last time, the Keyboard object became corrupt.

    This time, the Mouse object became corrupt.

    I really want to fix this problem so it never happens again, but I cannot find what the problem is without steps to reproduce the problem! Anything you can remember you were doing before the problem happened would be useful...

    I wish I could, don't remember at all.

  • Ashley Kyatric

    ok when i saw this capx i tough the problem will be from preview browser because many times i downloaded capx with firefox broswer and i don't have firefox browser on my laptop when i click preview i get crash but i think this problem fixed no crash just error message... so its not this problem..

    i said maybe from events so i tried delete sheet1 and play still crash , sheet1+2 and crash , sheet1+2+3 and also crash so its not events problem.

    so after that i saw he put really big numbers for example 10000 width of layout and about 70 sprites o.o ( i think he didn't hear of frames)

    anyway i tried to lower the width to 100 and still crash wth!!!

    so finally i saw sprite and deleted like 60% of them and it works fine so the problem is 1 from 2 :

    1) construct2 can't get that much of objects (too much).

    2) ( the thing i believe its the problem) is that sometimes when the layout doesn't contain the sprite it crash because the sprite doesn't know what is it... for example if you have (sprite1,sprite2) and have event that set sprite1 position on sprite2 and layout doesn't have the sprite1 (inside the page) it get crash... maybe this a normal problem if you see some capx they put some sprites outside the layout like some shoots and enemies... see (breakout tutorial by prof.s ) he put the shoots,blocks,.. outside layout to not get crash if he delete them he will get crash as i remember..

    so this isn't big problem.. <3

    so thanks for reading

    by salem ^^

  • I would post my own bug report but I don't get some of the things required to be stated but this is similar or maybe even the same problem I'm having. I created my project five times already getting only 20-40 minutes of creatation before construct 2 stops working. When contruct 2 stops working, even though I know I've saved the last 2 projects, disapear. Maybe that's what he means when being currupt (I don't really get what it means). Constuct 2 for me crashes after I just click where I want my spirte or object to be added. Also ever since the first crash and realizing that I couldn't find it, I've saved more frequently and closed my game manualy. When I reopened my project I got an error saying something about not being able to load textures and stuff so when I looked at my only layout, the ground was missing and the main character who I added animation wern't showing up. When I looked in the Project list they are there but to the left of the name it is just a blank rectangle. When I click the names of the objects, no blue highlighted thing goes over anywhere where I know I had the objects before I closed contruct. This happened about 3 times to me and when it did I just started over. Not including the 5 crashes by the way. And Now when I try running my project I get a error. When I close the error it pops up again and when I close it the area that should be my game startup screen is grey. Thanks for reading I'm sorry I can't post my own but those are just details which I could provide.

  • Also another thing is the first time construct crashed was yesterday and I had version 86 of construct. After the 4th crash I installed the newest version which is 90 and it still crashed. When I install a new version it uninstalls construct 2 automatically and reinstalls it with the newest version. I don't controll that so if my statement is valid then reinstalling doesn't work.

  • zsangerous - if you ever have a .capx that crashes, please immediately post it to this bugs forum. We can often fix the problem so it never happens again. Unfortunately without the .capx we cannot do anything.

    @BlueMan Project - it sounds like you have a different issue. Try updating your graphics driver.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread sticky
763 305,629
asikanddestroy's avatar
asikanddestroy
Unread hot topic
0 Favourites
What are you playing?
135 15,345
Tetriser's avatar
Tetriser
Unread hot topic
94 11,273
grigrizljac's avatar
grigrizljac