0 Favourites

W8.1 Store App unhandled exception when launching

  • Hello,

    I made a game which launches and runs fine in HTML5. It compiles in Visual Studio, passes certification both locally and Microsoft's, but then when it's downloaded from the Windows Store, I get an unhandled exception and the app does not launch at all. Here's the relevant information including the stack trace:

    Source Line Number:<2416>, Source Column Number:<4>, and Stack Trace: ms-appx://21588pixelnoms.bustersadventure/c2runtime.js:2416:4           loadTexture(object, boolean, boolean, number)
               ms-appx://21588pixelnoms.bustersadventure/c2runtime.js:20441:3           loadTextures()
               ms-appx://21588pixelnoms.bustersadventure/c2runtime.js:20468:4           onCreate()
               ms-appx://21588pixelnoms.bustersadventure/c2runtime.js:4372:3           createInstanceFromInit(object, object, boolean)
               ms-appx://21588pixelnoms.bustersadventure/c2runtime.js:7081:5           createInitialInstances()
               ms-appx://21588pixelnoms.bustersadventure/c2runtime.js:6264:4           startRunning()
               ms-appx://21588pixelnoms.bustersadventure/c2runtime.js:3949:3           doChangeLayout(object)
               ms-appx://21588pixelnoms.bustersadventure/c2runtime.js:3898:4           logic()
               ms-appx://21588pixelnoms.bustersadventure/c2runtime.js:3759:3           tick()
               ms-appx://21588pixelnoms.bustersadventure/c2runtime.js:3667:3           go_textures_done()[/code:2togcbby]
    
    I am able to download and launch it on my computer (where I also compiled the app). It's not a certificate issue, and it's not a driver issue. I have a test box sitting beside me with a clean install of Windows 8.1 and I'm unable to launch it on that box. The APPX installs just fine (as does the certificate) and runs fine. It's just the Store version that doesn't work. Any idea why? Or, is this something that Microsoft should be looking at? I brought it up here cause it seems to have a C2 stack trace.
    
    Thanks
  • Hi,

    I spoke with Microsoft support folks who helped me debug the issue. Here's a bit more information:

    https://dl.dropboxusercontent.com/u/290 ... 79-0-1.jpg

    https://dl.dropboxusercontent.com/u/290 ... 79-1-2.jpg

    https://dl.dropboxusercontent.com/u/290 ... 79-2-3.jpg

    Looks like IndexSizeError appears to be the culprit. I'll pursue this with Microsoft Support, but it would be good to get some insight on this class from Scirra devs so MS has more to go on.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Closing, please follow the bug report guidelines. We can't help with only the information provided.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic Locked topic
223 15,821
Tom's avatar
Tom Construct Team Founder
Unread hot topic
84 11,520
ultrafop's avatar
ultrafop
Unread hot topic Locked topic
115 17,198
Kyatric's avatar
Kyatric Construct Team Support