0 Favourites

Unexpected Sprite Clone/Trail

  • Sorry my bad english...

    Problem Description

    This is my first project as multiplayer game. I'm very happy because I have finished basic features as I expected although I got many problems related networking syncing.

    For a few days I observe and testing my project to see if the basic game play and performance work as what I want. Finally I got problem with something that I can not handle by myself. I don't know what I have to do.

    This is brief of my problems:

    Video Preview

    https://youtu.be/hhmKP0wYO9M

    My Project

    https://www.scirra.com/arcade/multiplayer-games/naked-shooter-18134

    Attach a Capx

    https://www.dropbox.com/s/0qy2nhw7znn9x0x/bug.capx?dl=0

    Description of Capx

    this is simple movement right, left, up, down multiplayer game

    Steps to Reproduce Bug

    • make the Browser gets highly process, you can try to open alot of websites in another tabs and open another software until the browser get freezed at a moment. It assumed that you have make complex project that consume high resources.
    • move the char, then it will make a clone / trail / duplicate at previous position

    Observed Result

    When the game starts and the system is on stable condition, the game is work nice as expected, but it will gets crazy when CPU get high process. The sprite makes clone itself on the previous position just like the system didn't have chance to remove it. So, I assume that if CPU or network latency get high process, construct did not execute event frame by frame properly.

    Expected Result

    The system remove sprite properly when it move / the events execute frame by frame properly even if the CPU or latency get high process.

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)
    • Internet Explorer: (YES)
    • Android (YES)

    Operating System and Service Pack

    Windows 7 & Android

    Construct 2 Version ID

    Construct 2 Release 244 (64bit)

    Additional Info

    I use Container Pluggin and link it to the char sprite and and attributs then syncing the container to the host.

    -----

    I hope you've got what I describe above. I'm very confusing to solve this problem. I hope you can fix the bug so I can finish my project on alpha version. So, please help me.. my project is nearly perfect... the problem is very annoying me... my fate on your hand now.

  • My .capx is very confidential. I don't want anyone to copy my project. So, please to understand. My compiled project attached on the link above. Please don't close this thread until I can solve it.

  • My .capx is very confidential. I don't want anyone to copy my project. So, please to understand. My compiled project attached on the link above. Please don't close this thread until I can solve it.

    Your post doesn't follow the Bug Report Requirements which means it is likely to be closed without investigation, specifically:

    [quote:22jza5nu]If you do not include a link to a .capx file demonstrating the problem you are reporting, your report will be immediately closed without being investigated.

    and also

    [quote:22jza5nu]Your .capx should be a minimal project made from scratch demonstrating the problem with as few events and objects as possible. Either build it from a new empty project, or delete everything you can that does not directly relate to the bug.

    A full project is usually too difficult to investigate as there is a big chance it is a user created bug rather than a bug in the software.

  • Ok ok don't close this thread.. give me time to make a sample related my project. But, would you like to consider to investigate the problem without my .capx for awhile (the compiled link attached)? Because i suspect this is the high CPU resource issue that construct can't handle event frame by frame properly. Please anyone to support my argue

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Ok, the .capx file attached.. so please scirra help me! thanx

  • The project uses third-party addons. Closing, please see the bug report guidelines.

  • Ashley

    Ok i forgot to remove the Z-sorter, but why you didn't warn me first then I can fix my attachment?

    Can you just a little bit friendly with me?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)