0 Favourites

Sprite scale r169

  • Sprite scale

    In my "Alex The Allegator Demo" , somes sprites are unscale with r169 , but not with r168.

    Attach a Capx

    https://dl.dropboxusercontent.com/u/164459914/scale_bug.capx

    Description of Capx

    The same sprite , on left 1:1 , on right scale 2x

    Steps to Reproduce Bug

    Export with r168 or r169

    Observed Result

    with r168 , no problem

    with r169 , sprites are scaled , and with a lot of sprites, all are unscale

    Expected Result

    no scale

    Affected Browsers

    • Chrome: YES
    • FireFox: YES

    Operating System and Service Pack

    Win7 x64 sp1

    Construct 2 Version ID

    r168 / r169

  • Nothing bad happened to me.

  • Scale perfectly, look to see if you use third plugins.

  • hello, try it online (html5), no problem in preview browser/node...

    i have the same problem in my game

  • anata

    In steps to reproduce, you say to export, but export as what?

    I exported your project as node-webkit, which is how you have it setup, and it scales and runs perfectly.

  • This might or might not be be related, but yesterday I exported an existing project with r169 and all my sprites were displayed half-size, for no apparent reason. In my case I removed the touch object, re-exported and it was OK again.

  • With r168 :

    With r169 :

    For all Player/Enemies i use a sprite for anim. No plugin for this.

    So wtf.

  • anata that is exactly what mine looked like, same problem!

    I realise that to fix it I actually did 2 things; remove the touch object and remove any WebGL effects throughout the whole project.

    If you use either of these then maybe you can remove them in a test version? If it fixes the problem then we may be closer to a solution at least.

    Edit: I also think on mine that it only happened to sprites with animations in folders, not 100% on that though

  • anata that is exactly what mine looked like, same problem!

    I realise that to fix it I actually did 2 things; remove the touch object and remove any WebGL effects throughout the whole project.

    If you use either of these then maybe you can remove them in a test version? If it fixes the problem then we may be closer to a solution at least.

    Edit: I also think on mine that it only happened to sprites with animations in folders, not 100% on that though

    right, only with animated sprites for me too

  • I think it would help greatly if those who say they experience the same issue could also post a small .capx with steps to reproduce the issue, as it doesn't look at all clear what the issue is at the moment.

    @SecondDimension, tawny what about it guys?

    Also, does the example anata posted show the bug for you two or does the scaling look OK?

  • hop, try to export a node with downscaling "high quality", there is the bug !

  • I'm having the same thing with every pixel based project no matter what export type I try and no matter what the (new) downscale setting. If I have time tonight I'll provide a capx, but I have a feeling this will be an obvious fix as it's clearly only happening with sprite sheets.

  • For clarity I think the issue is this:

    Exported HTML5 or Node-Webkit projects reduce the scale of animated sprites by 50%

    However as I said, I did fix it. I believe I solved my issue by doing one of the following things:

    • Removing Touch Object
    • Removing WebGL Effects

    I say that because those are the only things I changed before re-exporting and that seemed to solve it.

    I'm at work now, but I'll try to recreate the bug in a simple .capx later.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • The thing is, not everyone is seeing this unscale bug anata is referring to, which implies other factors must be involved.

    I've tried the suggestion of changing the new 'Downscaling' option from the default of 'Medium' to 'High' and that does produce a strange offset bug, but not an unscaling bug.

    With Downscaling set to 'High', the unscaled sprite is no longer at the same horizontal position as the scaled image. So something is definitely amiss there.

  • With the "Low Quality" or "Medium Quality" for Downscaling , all are good, but with a strange offset bug.

    With the "High Quality" for Downscaling, animated sprite are 50% unscaled.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
0 Favourites
Sprite Font Generator - v3
368 112,377
RetroDaddy's avatar
RetroDaddy
Unread hot topic
86 28,721
St4rDu57's avatar
St4rDu57
Unread hot topic
153 104,455
DravenX's avatar
DravenX