Specific layout bugged: Can't add and select objects

  • Problem Description

    I can't select objects on a specific layout. The other layouts are fine, it's just this one which is bugged. Already tryed to restart C2, restart PC, duplicate layout (duplicated layout is still bugged).

    Attach a Capx

    Can't share to public. Not a problem to send via PM. Recored a video, tho.

    Description of Capx

    No capx

    Steps to Reproduce Bug

    Don't know for sure, but here are something I did before the layout bugged.

    • Cloned some objects
    • Renamed objects cloned
    • Forced Copy Paste of new sprites inside project folder (of the cloned objects) [I did this before and it worked fine]

    Observed Result

    Selected objects dosn't show as selected. New objects added to layout won't show on the layout. Yet, the new object will work fine on the game If I try to run it.

    Expected Result

    New objects added to layout to work fine. And "select objets" functionality to work too.

    Affected Browsers

    Not really a browser problem.

    Operating System and Service Pack

    Windows 10

    Construct 2 Version ID

    r259

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • After trying pretty much everything I created a new layout, copied ALL objects of the bugged layout to another layout (using the "select all" command from the task bar and ctr+c, since I couldn't see the objects selected). And it WORKED. Now not only I can see the "invisible" objects added to the previous bugged layout, but the bugged layout is now working fine.

    Don't now why this happened, but I'm happy I can get back to work on my project again. (:

    I'm still sure it was a bug, so maybe Ashley may want to look into this latter.

  • Closing, please see the bug report guidelines. We can't debug videos.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)