Sometimes C2 deletes plugins/behaviour on reinstall

  • Problem Description

    Sometimes after C2 re-install/update i'm missing some/all previously installed third party plugins and behaviours.

    Attach a Capx

    Non applicable

    Description of Capx

    Non applicable

    Steps to Reproduce Bug

    • Install C2
    • Install third-party plugin/behaviour
    • reinstall/update C2

    Observed Result

    After reinstall sometimes i'm missing all/some plugins/behaviours. I saw this problem multiple time, although i couldn't pinpoint what causes this issue so i refrained from posting this issue. On average every 15 re-installs i loose some plugins. Also, i've done multiple re-installs of my whole system in between this bug occurring, so i'm 99% sure it's not linked to my system. Seems that uninstall sometimes cleans the whole install folder. Maybe it's possible to load third party plugins from some external location on hard drive?

    I haven't saw any posts of this problem so i'm not sure is this a problem on my side, but it happened again after updating to r175 so i'm posting here. Also, i'm interested am i the only one seeing this problem.

    Expected Result

    All third party plugins and behaviours remain intact

    Affected Browsers

    non applicable

    Operating System and Service Pack

    win 7 ultimate

    Construct 2 Version ID

    r175, although i'm seeing this for some time now.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Closing as cannot reproduce. Updates do not wipe installed plugins, since they are also installed to %appdata%\Construct2\plugins which the installer should never touch. If you delete this folder as well as the install directory, all your plugins will consequently be uninstalled. You are probably somehow doing that.

  • [quote:3g252y0v]Updates do not wipe installed plugins, since they are also installed to %appdata%\Construct2\plugins which the installer should never touch. If you delete this folder as well as the install directory, all your plugins will consequently be uninstalled.

    Thanks for the reply, this explains a lot! Since nobody seems to be able to reproduce this, problem is obviously on my side.

    Cheers!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)