0 Favourites

Setting The Mouse Cursor To "None" Is Not Working (Firefox)

  • Problem Description

    As the title says, the action to set the mouse cursor invisible (none) is broken in Firefox.

    Attach a Capx

    Download the capx there.

    Description of Capx

    Simple example to reproduce the bug.

    Steps to Reproduce Bug

    • Open the capx and enter the preview in Firefox
    • Click on the "none" button
    • Notice that the mouse cursor is still the same

    Observed Result

    The action to set the mouse cursor to none doesn't seem to work in Firefox.

    Expected Result

    The mouse cursor should be invisible after clicking on the button.

    Affected Browsers

    • Firefox: (YES)

    Operating System and Service Pack

    Windows 7 with latest updates and up to date drivers.

    Construct 2 Version ID

    Newest release r244 Steam release. [Personal Edition]

  • works for me. I'm on win 10. and the latest stable ff browser.

    try updating your FF browser

    "Note: cursor: none; is not supported until Firefox 3, Safari 5, and Chrome 5. Not at all supported in IE or Opera. "

    https://css-tricks.com/almanac/properties/c/cursor/

  • works for me. I'm on win 10. and the latest stable ff browser.

    try updating your FF browser

    "Note: cursor: none; is not supported until Firefox 3, Safari 5, and Chrome 5. Not at all supported in IE or Opera. "

    https://css-tricks.com/almanac/properties/c/cursor/

    I did reproduce this in Firefox v53.0 (32-Bit) which is the latest stable build.

    Could this perhaps be an OS related issue?

  • I don't know. I just blew the dust off my old windows vista and gave it a try. It didn't work at first but after updating firefox it also works. I don't have a win 7 so I can't check that system.

    You could look through you're mouse settings and see if there's anything that maybe interfering. I think some of the windows themes affect the mouse properties too so you could try switching to the basic theme if you aren't already using it. Check if you have any ff plugins that could affect the cursor. Other than that I'm out of ideas.

  • I don't know. I just blew the dust off my old windows vista and gave it a try. It didn't work at first but after updating firefox it also works. I don't have a win 7 so I can't check that system.

    You could look through you're mouse settings and see if there's anything that maybe interfering. I think some of the windows themes affect the mouse properties too so you could try switching to the basic theme if you aren't already using it. Check if you have any ff plugins that could affect the cursor. Other than that I'm out of ideas.

    Switched off Aero, disabled script + adblockers and it's still the same.

    I really think this is a Firefox on Windows 7 issue but I can't be 100% sure.

    Would be nice if other Win7 (64bit) users could check this out and share their results.

  • No problem here with Firefox 53 (32Bit) and Win7(64Bit). Works how it should.

  • No problem here with Firefox 53 (32Bit) and Win7(64Bit). Works how it should.

    Could you do me a quick favor and playtest this game: https://www.scirra.com/arcade/action-ga ... game-16921

    You shouldn't be able to see the mouse cursor at all, however on my end it's there using Firefox.

  • Works like you intended.

    The mouse pointer is the lighter spot above the text-bubble. I suppose that is like it should?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Works like you intended.

    The mouse pointer is the lighter spot above the text-bubble. I suppose that is like it should?

    Weird, I guess it's an issue on my end. No clue about the cause of this issue though.

    Yeah that's intended behavior by the way. Thanks for testing.

  • Works OK in Firefox here. Note you have to move the mouse off the button to see the correct style; I suppose the button uses its own cursor style (which seems sensible).

  • I've recently switched over to the 64bit version of Firefox and that pretty much "fixed" this issue.

    I have no clue what's wrong with my 32bit version but it doesn't really matter anyway, since this is clearly an issue on my end only.

    Thanks for all the responses in here again.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread sticky
4,517 857,207
Tinimations's avatar
Tinimations
Unread sticky
1,586 437,235
matriax's avatar
matriax
Unread hot topic
378 33,253
part12studios's avatar
part12studios