0 Favourites

Screen flickers

  • Problem Description

    There's a topic related to this issue which describes the problem ().

    Screen is sometimes flickering when there's an Audio action.

    Video of the problem which I made some time ago:

    This bug occurs only in fullscreen with NWjs 0.14.x and higher.

    Attach a Capx

    (There is another capx attached at the bottom of this post)

    Description of Capx

    I've added some background image so the flickering can be easily noticed. The capx itself is just a Audio->Play(tag) / Audio->Stop(tag) switch after each LMB click.

    Steps to Reproduce Bug

    • Run the project in fullscreen
    • Keep clicking LMB untill you see flickering (usually it takes less than a minute of fast clicking to notice)

    Observed Result

    Screen flickers from time to time

    Expected Result

    Not to flicker

    Affected Browsers

    • Chrome: (NO)
    • FireFox: (NO)
    • Internet Explorer: (NO)
    • NWjs version 0.14.x and higher: (YES)

    Operating System and Service Pack

    Tested on two machines:

    == Machine 1

    Windows 10

    GPU: nVidia Geeforce GT 635m

    CPU: Intel i7

    == Machine 2

    Windows 10

    GPU: Intel(R) HD Graphics

    CPU: Intel(R) Celeron(R) CPU N2840 2.16 GHz

    Construct 2 Version ID

    r239 (this issue orruced in previous C2 versions as well)

    EDIT

    Here is fully automated CAPX: https://drive.google.com/file/d/0BwT_0lczDpc9UHNHdWJJYjF4bjA/view?usp=sharing

    You just need to run it and wait.

  • At first I thought it was the inverted logic:

    Inverted, or negated doesn't always work as expected so I strongly suggest staying away from it.

    But then I replicated the effect by hitting the windows button, so I don't think its audio related.

  • I could not reproduce, I though it had something to do with one of the NWjs processes but I somehow doubt it now.

    Either way, I've noticed that one of the three processes is slowly but steadily increasing in memory use.

    This might have an impact on low-end devices but I'm not sure, I will keep on trying to reproduce it on my end.

    EDIT: Do you guys use dual-screen setups or one single screen?

  • I could not reproduce, I though it had something to do with one of the NWjs processes but I somehow doubt it now.

    Either way, I've noticed that one of the three processes is slowly but steadily increasing in memory use.

    This might have an impact on low-end devices but I'm not sure, I will keep on trying to reproduce it on my end.

    EDIT: Do you guys use dual-screen setups or one single screen?

    Dual-screen here, but the second machine I tested it on was purely on the laptop so one screen.

  • > I could not reproduce, I though it had something to do with one of the NWjs processes but I somehow doubt it now.

    >

    > Either way, I've noticed that one of the three processes is slowly but steadily increasing in memory use.

    > This might have an impact on low-end devices but I'm not sure, I will keep on trying to reproduce it on my end.

    >

    > EDIT: Do you guys use dual-screen setups or one single screen?

    >

    Dual-screen here, but the second machine I tested it on was purely on the laptop so one screen.

    Alright another possible issue out of the way.

    Are you able to open the dev-tools and look inside the console for me? (NWjs plugin action > Execute on start of layout)

    I'm using a nightly build and it doesn't work for me for some odd reason, this could possibly mean that the new version has fixed this issue.

    Please share the content of the console, error/warning or whatever messages it lists you there.

  • Are you able to open the dev-tools and look inside the console for me? (NWjs plugin action > Execute on start of layout)

    I'm using a nightly build and it doesn't work for me for some odd reason, this could possibly mean that the new version has fixed this issue.

    Please share the content of the console, error/warning or whatever messages it lists you there.

    Just some initial info's on start. Nothing new in the console while it flickers.

  • Just some initial info's on start. Nothing new in the console while it flickers.

    It's a really weird issue, did someone test it on Win7 already?

    I see a lot of Win10 setups but no Win7 tests except mine.

  • BackendFreak If this gets fixed after this report you get a statue!

  • I did a test, I still use vista

    but couldn't reproduce. I use r237 and nwjs 0.15 i think, and i get these errors:

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I'm not able to reproduce the flickering effect

    tested with c2-216 nw12 (export win64) and c2-239 nw18.5 (export win64)

    on I7-990X/24Gb/GTX970x1 same with GTX970x2 win7Pro-64b

    on I7-4770K/16GB/GTX770x1 win7Pro-64b

  • So it looks like it's Win10 (or Win8+) related issue as no one on Win7 is able to reproduce the issue.

  • Please provide your OS information, I would like to make sure that this is not a bug caused by buggy drivers and/or Win10.

    We have to somehow identify the cause of this bug and then hope that Ashley or the NWjs team will fix it.

    ---

    The bug is not occuring on my end, I'm using:

    OS: Win7 (64bit)

    NWjs: v0.18.5 & v0.18.6

  • Just an update.

    Two people from C2 Discord channel () tested the capx as well.

    The first person with Win 10 could see the flickering, the second person with Win 8.1 could not see the flickering. So again it looks like Win 10 issue.

  • Just an update.

    Two people from C2 Discord channel () tested the capx as well.

    The first person with Win 10 could see the flickering, the second person with Win 8.1 could not see the flickering. So again it looks like Win 10 issue.

    you forgot to mention win8.1 also has no problem recording the screen gameplay.

  • you forgot to mention win8.1 also has no problem recording the screen gameplay.

    Yeah but that's off topic. Recording issue post is here. We will have to do some more tests there as well.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)