0 Favourites

Rotate Image Distorts Images as well as Rotating them.

  • Problem Description

    when I go to rotate an image by 90 degrees, the image does rotate in terms of dimensions, but the image gets skewed at the same time.

    Description of Capx

    it is simply a truck graphic on the scene.. nothing more..

    Step 1

    open the file

    Step 2

    double click on the truck graphic

    Step 3

    go to rotate the image by 90 degrees either way in the graphic editor..

    Observed Result

    see the distortion.. click it a 2nd time making it a total of 180 degrees and you'll see it's back to normal...

    Expected Result

    it should just rotate by 90 degrees and still look like itself..

    Operating System and Service Pack

    running windows 8.1 on a Macbook Pro i7

    Construct 2 Version ID

    R175

  • Works fine here.

    Id say the Macbook Pro i7 thing is a big hint, but it may just be the graphics card.

  • I found a way to limp along with it, which i'll go into detail below..

    but in the editor it does this weird distortion thing.. it seems weird that something so specific inside the video card would cause this. also its something that only began happening in R175.. which introduced a new feature that allows mass editing of animations and stuff.

    So it seems very likely that those changes introduced a problem like this. Also I noticed if I do a 90 degree.. see the distortion and close it out.. then the image is correct.. doing this each time for all 4 directions then the rotation works fine.. however i also noticed if i do a number of "rotate 90 degrees" several times, not closing the window with each rotation.. then the image can end up looking like this:

    if it were a video card problem, i would imagine that the images would not be consistent.. in their own inconsistent way.. unless C2 is somehow doing some very video card specific calls maybe.. it does seem like a kind of buffer issue, but its just odd that it's so specific to this one view.

  • Can't reproduce in Windows 8.1 (non-VM). This looks like a VM issue perhaps. I don't think we can do anything to fix it I'm afraid.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • No I'm using Bootcamp, but understood being unable to reproduce it. I really don't get what it could be. I am going to update the video drivers and see if that helps

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)