Renaming and changing textures

  • There seems to be an obscure problem when renaming objects. If you rename the object the same as another object which you deleted from the project it would cause problems. At one point my "light" just appeared as a white square rather than a centred gradient and wouldn't fix til I renamed the objects back to their original names.

    Seperate to the above problem is that I changed a texture and it didn't update til the second time I previewed the game.

    Sorry for being vague, I will try and upload an example for the first problem!

  • I had that JSON error as reported as well completely knackerd my game as I saved it! <img src="smileys/smiley13.gif" border="0" align="middle" /> That involved deleting an object from the project window then renaming another object as the same name as the object deleted.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • We've had a number of bug reports like this - I'm aware of an issue but I can't reproduce any problem here, so it's very difficult to fix. It would be incredibly useful to have a .capx and a fixed set of steps that reproduces the issue... any chance you could come up with that? In all my testing using C2 myself I've never had this issue, so everyone must be doing something different to me. I'll double check the code anyway.

  • Not sure how to show the first problem but the texture problem you can recreate. Create two objects with different textures and delete one from the project window now rename the other sprite the same as the one you deleted. Preview it and the renamed object has the same texture as the deleted. Preview it again and everything is ok. Wonder if this might be related to the first problem. It's got something to do with deleting objects anyway.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)