0 Favourites

r80 Bug When Creating New Group

  • Received this shortly after installing r80, created a new group and this popped up.

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Getting event sequence number from event without one assigned

    Condition: sequence_number != 0

    File: Projects\Event.cpp

    Line: 30

    Function: unsigned int __cdecl Event::GetEventSequenceNumber(void) const

    Build: release 80 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort   Retry   Ignore   

    ---------------------------

  • hmm, just got it again. seems to be happening each time I try to add a new event/sub-event?

  • ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Getting event sequence number from event without one assigned

    Condition: sequence_number != 0

    File: Projects\Event.cpp

    Line: 30

    Function: unsigned int __cdecl Event::GetEventSequenceNumber(void) const

    Build: release 80 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort   Retry   Ignore   

    ---------------------------

    Just got something similar when I added an Event Sheet Include

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Can you check this is fixed in r80.2?

  • At work right now :/ but I can check in the evening for sure!

  • Yes, seems to be working just fine now!

    Nice job!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
0 Favourites
New Android Export Experiences
494 67,275
jabk's avatar
jabk
Unread hot topic
410 84,620
MrMegawatts's avatar
MrMegawatts
Unread hot topic
392 34,831
Joannesalfa's avatar
Joannesalfa