0 Favourites

[r68] Keyboard controls not working correctly

  • http://www.amirai.net/bugs/keyboardcontrolsbug.capx

    There are 2-3 bugs with this .cap. First, make sure you test with chrome.

    BUG 1 - Keyboard control problem

    Run the .capx, click and hold down the left mouse button, and make sure to drag the mouse a bit afterwards - the bug doesn't happen if you only click without dragging. Then, without releasing the mouse button, press w, a, s or d to move the circle. Most of the time, there's about a half second delay before the ship actually moves.

    Release the mouse and key to 'reset' the bug, as it won't happen again until they're not pressed. Try again, this time moving the ship diagonally. The second key pressed works immediately, as the bug hits the first key pressed after the mouse is clicked and dragged.

    Occasionally the ship continues moving in a direction when a key is not pressed as well. I'm not sure how to reproduce that, though. Just moving around, changing directions quickly and clicking a lot often does it, and the ship only stops if you press the direction its moving in again.

    BUG 2 - Firefox and IE don't display anything

    Switch the preview browser to IE9, run it. Nothing appears in the window. Firefox doesn't display anything either.

    BUG 3 - IE sometimes doesn't open

    Also, after closing the IE window and rerunning the .capx, often IE doesn't open. It might be unrelated, but I also somehow got it to open chrome when IE was selected for the preview browser.

    Might be something quirky with how firefox is in an unconventional location on my computer, though (it was moved from its original install location), resulting in C2 being unable to preview in firefox.

    Vista, 32 bit, Nvidia 9800GT.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • May I just say that

    " Occasionally the ship continues moving in a direction when a key is not pressed as well. I'm not sure how to reproduce that, though. Just moving around, changing directions quickly and clicking a lot often does it, and the ship only stops if you press the direction its moving in again."

    Is a problem that I am also experiencing. It is very annoying and needs to be fixed.

  • Er, whoops - forgot to post the link. http://www.amirai.net/bugs/keyboardcontrolsbug.capx

  • I tried it, FF 8.0 in XP.

    I can't reproduce neither bug1 or 2.

  • Kyat, bug 2 seems to occur mostly in Chrome only.

  • I updated my graphics card drivers and browsers - regardless, even trying to preview a blank .capx, firefox 8 and IE9 don't display anything other than the frame that surrounds the game. Doesn't matter if webGL is on or off for firefox.

  • Arima, I suppose you are seeing a grey screen 'of death'. From my experience, this can be caused by a variety of things, from simple bugs with quirky things to plugins which have become broken.

  • I can reproduce the delay in #1, but the fact no other browsers does it makes me think it's a bug in Chrome. If it was in our code then the other browsers would do the same, so I think it's a problem with Chrome itself.

    For #2 Firefox always works fine for me, but IE9 sometimes opens blank. Again I have no idea why, because if I hit F12 to look for errors then refresh the page, it works. Again may be an IE bug.

    For #3, I don't know what to do about this because behind the scenes it simply launches a command like "firefox.exe http://localhost...". Some browsers ignore launch commands if the process is still alive but shutting down so maybe if you're launching and closing browsers rapidly it might be that.

    In short I think you're highlighting browser bugs rather than C2 bugs - I'm not sure there's anything here we can do to resolve.

    Edit: can you check yourself for errors in Firefox or IE? Press F12 in IE then refresh the page (it won't show errors that happened before you pressed F12). For Firefox try Ctrl+Shift+J or Ctrl+Shift+K, it will report all errors before that time as well too.

  • Ashley, I have observed the 8-directional bug in both chrome and (rarely) firefox. It is very severe and common in chrome and, upon testing, it is caused by clicking. I have seen it in Firefox only when changing tabs.

    I hope that something can be done about this, it makes a game almost unplayable.

  • Bug 1 - that's frustrating. Well, I hope they fix it soon.

    Bug 2 - At least for IE, I think it's a construct bug because a blank .capx works in version 67, but not in 68. Firefox 8 apparently hasn't worked since r65 (haven't tested earlier than that, though).

    R68 testing:

    IE9 - works the same as you described, doesn't work until f12 then refreshed.

    FF8 - Got this error when using the 'inspect' feature, but none otherwise:

    Warning: Use of attributes' nodeName attribute is deprecated. Use name instead.

    Source File: localhost/preview.html

    Line: 0

    As for bug number three, I don't even know. Sometimes it works repeatedly, sometimes it doesn't open, sometimes it opens chrome, sometimes it opens firefox. I haven't managed to find any pattern to it.

    Edit: actually, I found another couple of errors in firefox after testing bug 3, jumping between browsers, sometimes leaving multiple browsers open and sometimes not:

    Could not read chrome manifest file 'C:\Program Files\Mozilla Firefox 5\extensions\{972ce4c6-7e08-4474-a285-3208198ce6fd}\chrome.manifest'.

    Warning: XUL box for _moz_generated_content_after element contained an inline #text child, forcing all its children to be wrapped in a block.

    Source File: chrome://browser/content/browser.xul

    Line: 0

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread sticky
4,517 857,549
Tinimations's avatar
Tinimations
Unread sticky
1,586 437,369
matriax's avatar
matriax
Unread hot topic
378 33,278
part12studios's avatar
part12studios