0 Favourites

r64: crashes on preview or save: request for info

  • Hi all,

    A number of people have reported crashes when pressing save or preview in r64. Woops. Let's get to the bottom of this as quickly as possible.

    I have a feeling it might be specific to the 64-bit build. Is anyone having these issues in the 32-bit build of Construct 2?

    Also, if you're having problems with this and you're using 64-bit Construct 2, does switching to the 32-bit build make it any better?

    Edit: I think I've identified a possible issue and done a quick fix. Here's a beta of r65 (note: this isn't the real r65 release). If you've been having problems please install that and let me know if it works better!

  • Here, using the 32-bit version. (I'm in win XP, always installing as "auto-chose", assuming it should be 32 bits, confirmed by the "about" window. )

    Consecutively to the discovery of this bug on r63 in my entry's capx, I've encountered more and more crashes (on preview).

    You can get a "buggy" capx as well as comments in this report I filled earlier today.

  • 32 bit build and no problem saving - and no crashes yet.

  • 32 bit problem with preview in ff7 and totally bug cras when i save project and the worst I can not open your project (for competition)

  • 2 bit build and no problem saving - and no crashes yet.

    Same here.

    Operating System

    MS Windows 7 Home Premium 32-bit SP1

    CPU

    Intel Core 2 Duo E6850 3.00GHz

    Conroe 65nm Technology

    RAM

    4.00 GB Dual-Channel DDR2 401MHz (6-6-6-18)

    Motherboard

    ASUSTeK Computer INC. P5KPL-AM (Socket 775)

    Graphics

    SyncMaster (1920x108060Hz)

    1024MB GeForce 8800 GT (Undefined)

  • No crashes when saving or previewing.

    C2 r64, 64-bit

    Windows 7 Enterprise, 64-bit

    Chrome 14/15

    IE9, 32-bit and 64-bit

  • I've put up a beta of the next release which I think might fix this. If you've been having problems please see the link in the OP and let me know if it improves anything.

  • Scratch my earlier post, now i am having sporadic crashing when previewing, I'll add the error info if it happens again.

  • Nickydude, could you try the test build in the OP and see if that helps?

  • You forgot to add '.exe' to the end of the filename.

    construct2-r65-beta-fixtest

    <img src="smileys/smiley36.gif" border="0" align="middle" />

  • I thought I'd try and help out by beta testing this release, even though R64 is OK for me, and got the following crash when closing, straight after saving:

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Failed to remove directory '05BD21F0' (145)

    Condition: false

    File: Projects\Project.cpp

    Line: 89

    Function: __thiscall Project::~Project(void)

    Build: release 64 (32-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 145)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort   Retry   Ignore   

    ---------------------------

    .capx was THIS

  • Still crashing. <img src="smileys/smiley19.gif" border="0" align="middle" />

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Cannot find file on disk to return over HTTP

    Condition: FileExists(disk_path)

    File: HttpFileServer.cpp

    Line: 277

    Function: void __thiscall HttpFileServer::ServerRespond(struct _HTTP_REQUEST_V2 *)

    Build: release 64 (32-bit) checked

    Component: HTML5 exporter

    (Last Win32 error: 3)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

  • Lol, thanks for pointing out! I've updated the URL, any luck with the build?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • No, the above crash was with the new beta build.

  • Oops, didn't see the second page of posts. That's odd, the check failure is saying it's r64. Are you sure you installed and ran that test release and not some other version? I would have expected that dialog to say r65.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)