0 Favourites

[R59] Error report

  • ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Could not find behavior's combo property index

    Condition: index >= 0

    File: Projects\BehaviorInstance.cpp

    Line: 341

    Function: class cr::pod<class std::vector<struct era::InstanceProperty,class std::allocator<struct era::InstanceProperty> > > __cdecl BehaviorInstanceERACallback::GetProperties(void) const

    Build: release 59 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort   Retry   Ignore   

    ---------------------------

    This happened after I changed the physics property of one instance to immovable then selected the object in the project window and attempted to update all objects to immovable.

  • Huh, that's odd, usually it only occurs if I change the name of a combo property, but I don't think I did in r59. If you ignore it does it work OK? Can you reproduce every time?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Download my plugin here.

    Extract the behavior to the normal folder.

    Run my example project (this isn't some self promotion!).

    Select a tree.

    Add the Physics behavior and set the immovable property to true.

    In the project pane on the right select the tree so it selects all trees.

    Set the Physics immovable to true.

    Now, select the drunk guy and add Physics to his behaviors.

    Run project.

    Clicking ignore works. It ignores a few times then runs the project.

    Is this something to do with my behavior? Hope this helps! <img src="smileys/smiley5.gif" border="0" align="middle">

  • I got the same problem in my new project...

  • I see, it looks like when you mass-select the trees and set 'immovable' to 'yes', it actually blanks out the combo box. If you do it again, it works, but if you leave it blank it stays blank. Because it says neither 'yes' nor 'no, you get an error on export.

    It's easy to work around - just select the combo twice and it works - but I'll try have it fixed before I go on holiday.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
119 7,534
Silverforce's avatar
Silverforce
Unread hot topic
42 8,217
Silverforce's avatar
Silverforce
Unread hot topic
34 8,632
Mirdov's avatar
Mirdov