0 Favourites

R214 BETA Android Crosswalk Not Play Music

  • Problem Description

    Android Crosswalk Export | Music Not Work ?

    Sounds Work Fine

    Test on LG G2

    Attach a Capx

    Description of Capx

    Super Galaxy Invaders ( Music Work in HTML & Windows 10 )

    Steps to Reproduce Bug

      On Start of Game Music not play In GamePlay Music not play

    Observed Result

    ____ What happens? ____

    Expected Result

    ____ What do you expect to happen? ____

    Affected Browsers

      Chrome: (NO) FireFox: (NO) Internet Explorer: (NO)

    Operating System and Service Pack

    Windows 10 Pro

    Construct 2 Version ID

    R214 BETA

  • To be honest i don't think that's a r214 fault. As far as I can remember XDK Crosswalk have always some issues with playing music for C2 music folder.

  • To be honest i don't think that's a r214 fault. As far as I can remember XDK Crosswalk have always some issues with playing music for C2 music folder.

    You're right, not fault r214 Beta, I tried in 212.2 Stable [ Music Not Work Again ]

    I can not understand how solve this problem ? The music work fine in HTML5, Chrome Mobile end Windows 10

  • put all musics in sound folder.

  • put all musics in sound folder.

    Thank you it, It works

    Very Little Slow in Bar Start Loading

    I Hope to fix this bugs

  • put all musics in sound folder.

    That's not a solution. That's necessary workaround, which will increase memory usage and load times.

  • > put all musics in sound folder.

    >

    That's not a solution. That's necessary workaround, which will increase memory usage and load times.

    You're right shinkan, Scirra or Intel should fix this problem in Crosswalk

    This problem occurs if use many music files in your game.

    but I'm not sure, because the other two games i have in android with many music files, they have no problems

  • It's Intel's problem not C2. Workaround is to put it into Sound folder but (if you don't have too many sounds) I suggest to disable global sounds preloading, and do it manualy on first layout start, excluding music. Then you won't waste initial loading time.

    EDIT: At the moment in my game I hear no music and even no sounds. So I really hope they gonna fix it soon.

  • It's Intel's problem not C2. Workaround is to put it into Sound folder but (if you don't have too many sounds) I suggest to disable global sounds preloading, and do it manualy on first layout start, excluding music. Then you won't waste initial loading time.

    EDIT: At the moment in my game I hear no music and even no sounds. So I really hope they gonna fix it soon.

    I Hope Intel to fix it. It's very nice the game start with music.

  • Same problem, this is a C2 issue, I have always used music and recently this has stopped working. I can go back to C2 200 and it works after exporting to xdk and building crosswalk apk. Using 212.2 and 214 I've lost all music.

    This is very easy to reproduce and I am surprised this isn't more widespread.

    Does anyone have an example of music working in an apk from the latest C2 builds?

  • Same problem, this is a C2 issue, I have always used music and recently this has stopped working. I can go back to C2 200 and it works after exporting to xdk and building crosswalk apk. Using 212.2 and 214 I've lost all music.

    This is very easy to reproduce and I am surprised this isn't more widespread.

    Does anyone have an example of music working in an apk from the latest C2 builds?

    I Sent message to IntelRobert

    I post the message, just answer me.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Oh here it's, i think this just happened to me lol

  • Can't reproduce. I published Space Blaster with the Intel XDK building for Android with Crosswalk, and the music (which is in the music folder) plays as expected on a Moto X (2nd gen) with Android 5.1. The original report does not include a .capx so I can't investigate this any further. This is why we ask that you always follow the bug report guidelines. Closing. Please file a new report following all the guidelines if you still have trouble.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)