0 Favourites

(r202) Audio does not resume

  • Problem Description

    Play audio 1.

    Pause audio 1 and play audio 2.

    On audio 2 finished, resume audio 1.

    Audio 1 does not resume.

    Attach a Capx

    https://drive.google.com/file/d/0B0gW1A ... sp=sharing

    Description of Capx

    Plays audio 1 on start of layout. On any key pressed it pauses Audio 1 and plays Audio 2.

    On audio 2 finished, it resumes audio 1.

    Steps to Reproduce Bug

    • Play Audio 1.
    • Pause Audio 1.
    • Play Audio 2
    • On Audio 2 finished, resume audio 1.

    Observed Result

    Audio 1 does not resume.

    Expected Result

    Audio 1 resumes.

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)
    • Internet Explorer: (YES)

    Operating System and Service Pack

    Windows 7 Home Premium SP1

    Construct 2 Version ID

    Beta r202

    You should relook at your "bug fix":

    "Audio: could fail to pause audio if it had previously been paused and resumed".

    In r201 everything worked fine, now it's not.

  • Actually the issue seems to be with the trigger "Audio ended" (or possibly this specific music, I haven't done complimentary tests).

    Check this example that builds upon the original capx.

    Use the up arrow to pause and play the new bit of audio.

    Use the down arrow to manually resume the audio 1.

    Notice how despite supposed to show a debug message, apparently the "On Audio 2 ended" condition never seems to happen.

    Tested in FF and NW.JS.

    I assume this will work the same in Chrome and possibly Explorer.

  • Actually the issue seems to be with the trigger "Audio ended" (or possibly this specific music, I haven't done complimentary tests)..

    It's definitely not the specific music, it's not working in my game either. So it's either the trigger or the action.

    I rolled back to r201 and deleted my r202 install, not going to bother downloading & installing it again.

    In anycase, Ashley needs to fix this.

    Thanks for confirming that I'm not the only one that has this problem.

  • Im suffering same bug. Got nuts trying to fix my code thinking it was something i wrote wrong.

    Edit: The bug its on "music ended" detection. On short sounds seems to work (sometimes), but not on music that its longer.

  • Same here I'm afraid. On sound ended doesn't trigger following actions.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Thanks, should be fixed in the next build.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
378 33,279
part12studios's avatar
part12studios
Unread hot topic
99 10,159
karshinkoff's avatar
karshinkoff
Unread hot topic Locked topic
115 17,218
Kyatric's avatar
Kyatric Construct Team Support