0 Favourites

[R186.2] Ejecta error on suspend / can't resume

  • Problem Description

    App crashes on suspend (home button pressed). Can't resume.

    Attach a Capx

    Attached basic empty project with 2 sprites.

    Description of Capx

    Empty project that displays 2 sprites.

    Steps to Reproduce Bug

    • Export to Ejecta unminified. Copy to App folder. Run in Xcode simulator. Press home button (Shift+Command+H).
    • Debug area logs error. (see below)
    • Resuming the app hangs. The same behaviou is found on hardware (iPad2)

    Observed Result

    Degug area states:

    2014-11-03 10:00:15.958 Super Golf World[787:90b] TypeError: null is not an object (evaluating 'context["suspend"]') at line 15161 in index.js
    [/code:mpg9g3l5]
    
    Looking at line 15161 in index.js, the code is:
    [code:mpg9g3l5]
    	instanceProto.onSuspend = function (s)
    	{
    		if (this.playinbackground)
    			return;
    		if (!s && context["resume"])
    			context["resume"]();
    		var i, len;
    		for (i = 0, len = audioInstances.length; i < len; i++)
    			audioInstances[i].setSuspended(s);
    LINE 15161>>>	if (s && context["suspend"])
    			context["suspend"]();
    	};
    [/code:mpg9g3l5]
        
    [b]Expected Result[/b]
    App should be able to resume from suspend without crashing. Worked fine on R184 and earlier versions. 
        
    [b]Affected Browsers[/b]
    Not applicable/iOS bug
        
    [b]Operating System and Service Pack[/b]
    Win8, 32 bit
        
    [b]Construct 2 Version ID[/b]
    R186.2
  • Oops, thanks for the report, should be fixed in the next build.

  • Ashley I am facing the same issue with my Windows Universal App 8.1(Phone).

    Whenever I press the WP Menu button to go to main screen and come back to the game, the App crashes.

    This has been happening with all earlier builds too.

    One observation is that , this started occurring after adding the Audio Object to the project. And happens only once a Sound file starts playing. After that it doesnt matter if the Sound is playing or not. The App just doesnt Resume back.

    Will test it on R189 built today.

  • SamRock - this is a closed bug report, the problem was fixed in r187. Please only test the latest version of C2.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • SamRock - this is a closed bug report, the problem was fixed in r187. Please only test the latest version of C2.

    Hi Ashley,

    I have tried this with the latest C2 version and still the compiled APP on my Windows Phone crashes. Also there are couple of JQuery errors that show up while running. I will create another thread for this:

    [quote:9ky5d5rt]

    'WWAHOST.EXE' (Script): Loaded 'Script Code (MSAppHost/2.0)'.

    Exception was thrown at line 2, column 10423 in ms-appx://5c4f7c91-0785-40c6-aa1a-e2aa55a4f001/jquery-2.1.1.min.js

    0x800a139e - JavaScript runtime error: SyntaxError

    Exception was thrown at line 2, column 10648 in ms-appx://5c4f7c91-0785-40c6-aa1a-e2aa55a4f001/jquery-2.1.1.min.js

    0x800a139e - JavaScript runtime error: SyntaxError

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)