0 Favourites

[R181] bug on closing

  • Problem Description

    ____ recieved this message when I closed out C2...

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Object texture leak: a texture is still loaded when cleaning up an ObjectTexture, check all textures released properly

    Condition: gl_instances.empty()

    File: Projects\ObjectTexture.cpp

    Line: 33

    Function: __cdecl ObjectTexture::~ObjectTexture(void)

    Build: release 181 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort Retry Ignore

    ---------------------------

    ____

    Attach a Capx

    ____ none____

    Description of Capx

    ____ posts above message when I try and close C2 ____

    Steps to Reproduce Bug

    • hapenned twice, but have been unable to reproduce it consitantly, but happenned directly after save and close both times. popup said it could be useful, so I posted it

    Observed Result

    ____ What happens? ____

    Expected Result

    ____ What do you expect to happen? ____

    Affected Browsers

    • Chrome: (YES/NO)
    • FireFox: (YES/NO)
    • Internet Explorer: (YES/NO)

    Operating System and Service Pack

    ____ windows 8.1 updated automatically ____

    Construct 2 Version ID

    ____ 181 ____

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Sorry, nothing we can do with just an error message, especially since this can be caused by third party plugins that we can't support. You'll need to follow the guidelines to get this investigated.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)