0 Favourites

[r128.2] C2 runs wrong preview layout

  • Link to .capx file (required!):

    dl.dropboxusercontent.com/u/41931267/LayoutBug.capx

    Steps to reproduce:

    1. Go to Layout 2 in the Editor

    2. Edit something in Layout 2 if you wish - not necessary

    3. Go to Event Sheet 1

    4. Run the game

    Observed result:

    Layout 1 appears

    Expected result:

    Layout 2 should appear.

    Note that if the order of layouts 1 and 2 are changed in the Projects bar, the effect is reversed.

    Browsers affected:

    N/A

    Operating system & service pack:

    Windows 7 64bit

    Construct 2 version:

    r128.2

  • Yeah I just noticed this as well, it is always running the bottom layout in the projects section.

  • Not the bottom layout in the projects section but last layout created - for me anyway.

    Layouts order in project bar doesn't matter or even which event sheet is currently open. It will always load last (recent) layout I created when I'm in events editor. I have to go to layout I want and press F5 to run it.

    It usued to load last opened layout in preview while you were editing events.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • shinkan

    Ah ok, maybe I should have mentioned the process then as well. I can click on any layout and hit preview, which works, but if I click preview from my event sheet it will always run the layout I put at the bottom of the Layouts folder in the project window.

    I just created a new layout to test and shifted it to the top of projects window and its still going to the one at the bottom.

  • GenkiGenga that's kind of strange. I just created a few layout in project I'm currently working on and it always runs the preview for one specific layout - last one I've created in r127.

    And again, layouts order doesn't matter. It goes for this one layout all the time when I'm in events editor.

  • shinkan, very strange. To add to this, I just played around with it a bit more using Squids example but I added another layer to it.

    db.tt/NTQuIHaO

    If you play this from the event window it should show the blank newly created layout 3.

    What I noticed was that if I keep it on the event window and put layout 1 on the bottom in the project bar - then hit play - It will still open up to the blank screen of layout 3 (using the on screen play button).

    But if I put layout 1 at the bottom of the project bar and then click on any layout tab and back to the event sheet it will play whatever is on the bottom (in this case layout 1)

    Maybe this is why we are reporting different things? If not I have no idea! :)

    Operating system & service pack:

    Windows 7 64bit

  • Should be fixed in the next build.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)