0 Favourites

[r127] Jump-Thru behavior bug

  • Link to .capx file (required!):

    dl.dropboxusercontent.com/u/2383513/jumpthru.capx

    Steps to reproduce:

    1. Create a object with a platform behavior

    2. Create a tiled background with a jumpthru behavior

    3. When the platform object is falling, go into the platform with the jumpthru behavior

    Observed result:

    In this .capx the object stops for a moment then resumes the falling, but in my game the character simply stops and walks in the middle of the platform.

    <img src="http://i.imgur.com/wBFsXIb.png" border="0" />

    Expected result:

    There should be no stopping at all, if an object with a platform behavior isn't at the top of the platform he should never stop.

    Browsers affected:

    Chrome: yes

    Operating system & service pack:

    Windows 8 64-bit

    Construct 2 version:

    r127 64-bit

  • I have been getting similar issues for the last few builds, seems to happen to me when I have jump throughs that are thick. It seems like it has a set height that it expects to use for the platform and if you use one that is thicker than that, you get some issues where it seems to detect that there is a solid platform underneath the jump through. This usually happens to me with jumpt through sprites where I run off the edge then immediately turn back the other way (back toward the platform) and my character will catch in mid-air just under the edge of the platform for an instant. Maybe not as bad as your issue, but still seems to be related.

    It's almost as if the jump through has some type of invisible semi-solid platform directly beneath it that you can get caught on some times.

    Happens in IE for me...

  • It should be easy to work around. Just make the jump-thru a thin bar along the top rather than a giant thick block. Still, I'll see if this can be fixed from the platform behavior.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Thanks Ashley!

    I've been thinking about doing that too, having a layer full of invisible platforms. Still, if I didn't have to it would be great. Thanks!

  • I find that when the platform is thin, the character can sometimes teleport through it when the framerate fluctuates or if the character moves too fast iirc.

  • I'm having the same problem, where it pauses momentarily part way through the fall. Making the platform a thin strip didn't help.

  • It just got worse with 135 - though I had to finish a project and stayed on 132 until it was finished. I keep getting stuck walking into jump thru platforms from the left or right. I haven't had any issue until now. Been building the game this way since March - not one issue. Now any level with jumpthru platforms is completely bugged. Awesome...

  • damainman Could you explain a little better? I tested here and it works just fine, the only bug I have is the one mentioned in the first post.

    Maybe your problem has to do with the collision polygon, I had some trouble with the platform behavior until I messed around with it a bit.

  • andreyin Sure! I have platforms set up at multiple heights. Like steps. So some of them will come up to the knees of the player sprite or to his chest - whatever.

    If I have one overlapping another for the appearance of stairs or steps that you can walk past or jump onto, the player will get stuck upon touching the second platform no matter what the height. The controls will stop responding. Also I've noticed since 132 enemies that bump into walls or even the player when he's knocked back will now get stuck in/sink through the platform tile. The zombies for example will just bang into the wall until they eventually slide through the ground/platform tile... This didn't happen pre 132 build. It just keeps getting worse and worse.

    I'm back on 132 and the getting stuck on the platform issue is now gone. So there is something wrong between 132 and 136.

    Also I get this stupid thing if the platform isn't a small strip, the player will kind of hang for a second before doing a complete jump past a platform... I'm going to go back as far as 126 and see what happens. I'm not using any features since 120 anyhow haha!

    The detection for platform/jumpthru is completely bugged.

  • damainman - post a new report, following all the guidelines, otherwise we can't provide any help.

  • damainman , I've noticed this has happened since the early version, I've had it where if the player Jumps, and is falling, and touches edge of Jumpthru, the players Y speed will go to 0 (like this diagram):

    (Green is the player, Red is Jumpthru, blue is how the movement goes)

    <img src="https://dl.dropboxusercontent.com/u/7765312/C2/jumpthru.png" border="0" />

    Also, having a Player colliding with multiple jumpsdowns that are sloped causes glitches (But can't blame the behaviour from 'behaving' weird (lol) as it's getting confused from handling multiple Jumpthrus)

    When it does this, it causes the behaviour to think it's not on the ground, though it is not actually falling towards ground, therefore you cannot jump ect.

    <img src="https://dl.dropboxusercontent.com/u/7765312/C2/Floatthrough.png" border="0" />

    The new update has introduced something that's all over my project, where I have solids and Jumpthrus close together, the character does the "Floaty falling" thing like the previous bug, just from walking along the solid into the side of the jumpthru.

    (Orange is solid)

    <img src="https://dl.dropboxusercontent.com/u/7765312/C2/Newpushdown.png" border="0" />

    I've bug reported just one bug (one I haven't mentioned here) as I believe some of these thing I experience may just be because I have a tall Player, and I may attempt to change it round so he's like 4x4px (I've tried it quickly and gives a lot less hassle with the jumpthrus) Except most of my project is based around using the Players size for gameplay collisions like fighting. Life choices. <img src="smileys/smiley16.gif" border="0" align="middle" />

  • Jase00 You just outlined every issue I'm having. I'm back on r132 so I can't check the 3rd issue you're having. But the 2nd issue you've described is the new issue I'm having and the reason I'm back on r132.

    @Ashley I work full time and this is my night time hobby - if I get a chance tonight, I'll write a capx that shows the issues Jase00 described above. It should be nothing more than a player sprite, and stacked jumpthru objects that cause the issue. Maybe on my break I can whip something up too...

  • damainman I believe that the 2nd issue has been around for quite some time now :P I kinda just ignored it and avoided having sloped jumpthrus having other platforms close by. Though it's nice to know this is affecting others and not just me :3

  • Jase00 Well the second one isn't quite the same for me. I would have stacked jumpthru tiles to give the look of steps or different sized platforms. This bug only started for me with the last release (r136). I don't float or anything. I just get stuck like I'm in the middle of a solid.

    And the slide through the floor thing I patched up with an "if enemy hits wall then enemy.y=self.y-1" And they no longer fall through the floor.

    I went to r135 for now. With the above patch I now have no issues aside of the silly hitting the platform from the side causes a millisecond delay from falling.

  • damainman Have you tried messing with your sprite collision box? Instead of dragging the points around, click them once and set it's X/Y position manually by setting the numbers. This fixed it for me!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)