0 Favourites

r114 Add event / action

  • Dear Construct team, here is a link to the file the bug started out with: dropbox.com/s/j3m2ra4zyw0zfic/PingPong.capx

    I added a subevent that tests if y is less or equal to ball's (obj) Y position. When I then clicked "Add action", Construct crashed, and when I tried other files etc. it happened as well. In short, the program freezes everytime I click "Add action" and "Add event", which makes it a serious bug.

    I use the latest Chrome webbrowser with Windows 7 64-bit (latest update) with a fully updated graphics driver as well. I have obviously tried to restart my laptop twice without any luck.

    It's quite random that it happened, because I have used Construct for some days without having problems with this.

    I'd however like to add that Construct has been crashing when pressing alt + 4 (browser preview) from the day i started (r114). This has however not been as bad, because I could just restart the program, and it only happened once in a while, but this happens no matter what.

  • No problem or crash for me. I've opened your .capx and can add actions, and events with no problem.

    The symptoms you describe are generally nothing to do with C2 but a conflict on your own system, usually graphic or system driver issue.

  • I have installed the latest graphics driver, and reinstalled CC2 without any luck, but I can see if there are any system driver updates. If not, then I suspect it's CC2.

  • Check this and that blog articles.

    What is your graphic card ?

    When you talk about previous versions of C2, are those stable or beta ?

  • Thanks for the links! I don't know the excact type because it was my brother's PC, and I don't have it anymore, but it was from Intel.

    I have only been using the latest release of CC2.

    I'm currently working with an old HP PC with Windows XP installed, and it works much better on this one. The only problem now is that the preview (alt+4) doesn't work in Chrome (it just loads forever), but it works in Firefox though.

  • XP isn't the better choice for C2 imo, but it's still better than nothing and I know it's not always possible to upgrade to better hardware/software.

    Ajnytime you have the opportunity to switch to a more recent computer and win7, don't hesitate ^^

    For the loading issue, maybe try pressing F5 or ctrl+F5 to force reload. The browser might then catch the local server and display the game correctly.

  • It works great on my XP for now, but I haven't tried making any hardcore, graphics intensive games yet, so I can see the issue it may cause on a 32-bit XP.

    Regarding Chrome, it works now! I don't know how it was fixed though.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • chrisriis: what service pack of XP are you using? We only support SP3 for Windows XP.

    I think this can be closed as an issue with your computer anyway, since this is the only report we've had and I'm sure we'd be inundated with reports if it was a problem with C2 that affected everyone.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)