0 Favourites

r111 - Open project uses wrong sprites/effects

  • Apologies for the vague topic title but I couldn't write all I wanted.

    Today I had a funky situation with C2. While I can't tell if it's a bug it sure doesn't seem intentional anyway, so here's what happened, step by step:

    Open Construct 2.

    Select "Browse Examples".

    Drag and drop an example file to C2 (don't close the Examples folder).

    Preview it in a browser tab.

    Close the browser tab.

    Return to C2 and close the project.

    Maximize/return to the folder again.

    Drag and drop another example.

    Launch it in the browser.

    While previewing, the sprites/effects of the last opened example replace whatever sprites/effects are present in the newly opened file.

    Imagine my surprise seeing this:

    <img src="http://s8.postimage.org/grjpt7cb9/wut.png" border="0" />

    Yes, those are several copies of the plumber sprite swaying like grass in the Sine behavior example <img src="smileys/smiley36.gif" border="0" align="middle" />. To replicate it follow the above steps and open the "Pick Nearest" example first, then "Sine behavior - grass". I also got standard "shiny" sparks in what was meant to be the Explosion particle example.

    I'm using Vista and the latest Firefox version (which got updated fairly recently - yesterday if I'm not mistaken?). And C2 r111, of course.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Closing as I am fairly sure this is a graphics driver bug; I couldn't reproduce any problem here. Try updating your drivers.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)