0 Favourites

r103 Simulate platform pressing Jump doesn't work

  • My platformer stopped jumping after r103.

    I use something like this:

    On mouse doubleclick left control -> Simulate platform pressing jump

                                      -> Play animation jump left.

    It does nothing but just play the animation.

    I also tried manually instead of simulate control .. using

    setX = player.X-500

    setY = player.Y+1000

    It seems to only do the setX part but not the Y part.

    Helps? <img src="smileys/smiley5.gif" border="0" align="middle" />

  • Simulate jump works fine for me in r103, you should include a .capx so we can try to find out what's causing it. And for the setX/setY; Y+1000 is downwards, so you need to subtract instead of add if you want it to move upwards.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Here's the capx.

    Buggy-Droid

    Double click on left half of the game screen to jump

    (I haven't written the right jump yet)

    It only plays the jump animation but doesnt jump.

    The related section in the EventSheet1 is "Mouse is doubleclicking object leftcontrol"

    <img src="smileys/smiley19.gif" border="0" align="middle">

  • This should never have worked, because there are no Solid or Platform objects in the layout. The Bound To Layout behavior is keeping the object in the layout, but only by overriding its position - technically the object is still in a constant freefall, which is why it can't jump.

    I have no idea why this would work before r103, since it's designed wrong. Perhaps a bug that allowed it to jump when in freefall was fixed. You must use solid or platform objects for the player to walk on in order for the platform behavior to work correctly.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)