Problems with second launch on ios.

  • Problem Description

    A game exported as HTML5 can't be launched second time on ipad without cleaning cache. It work's fine for the first time, but the next time, when I try to launch it on Ipad, it's just an infinite loading layout. The problem isn't only in Safari other browsers on ipad are stunned too. When I delete offline.appcache it works fine, so I think something wrong with it, unfortunately I don't know what.

    Attach a Capx

    [attachment=0:221dbdst][/attachment:221dbdst]

    Description of Capx

    A game, clone of flappy bird. You can launch it through this link :

    Steps to Reproduce Bug

    • Launch game on ipad using Safari.
    • Close it and shut down Safari (delete from active apps)
    • Try to launch it again

    Observed Result

    Infinity loading layout.

    Expected Result

    Run this game.

    Affected Browsers

    • Chrome: NO
    • FireFox: NO
    • Internet Explorer: NO

    Operating System and Service Pack

    ios 7.1

    Construct 2 Version ID

    Release 195(64bit)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Closing, please update to the latest iOS version (8.1.3 now I think) and report again if you can still reproduce there.

  • I have same issue with html5 game, but I don't want to update ios on Ipad (IOS 8 will fill my disk space ), same game works fine on iphone 4 with same ios version ios 7.1 and on other smartphones (android,windows phone etc) works fine as well.

    Only on Ipad clear cache is only solution?

    MIME types settings are OK on server.

    I am trying to figure out where is problem and after removing sounds from game everything is fine.

    m4a format is problem somehow

    P.S. I am noob to all this and this is my first try to make html5 game

  • setting > safari> privacy & security > do not track > turn off

    This fix problem for a while, but after loading few times it stop again, so it could be some ipad issue with privacy settings

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)