0 Favourites

Positioned Audio (HRTF Mode) Causing Game Freeze/Glitch

  • Problem Description

    Finding the cause for this glitch took me a while but I think that I've finally found it.

    My game is using positioned audio in the gameplay part and I've noticed that it takes up to 3 seconds to load in a layout.

    At first I thought it might be caused by the layout loading system but then I found out that positioned audio was at fault.

    Basically when the game is playing positioned audio for the first time, using the "HRTF" mode it comes to a complete hold.

    I'm sure that "HRTF" is at fault because "Equal Power" works as intended.

    Attach a Capx

    Click HERE to enter the download dimension.

    Description of Capx

    Holds an example scenario, pretty self-explanatory.

    Steps to Reproduce Bug

    • Select your preview browser and run the game in preview mode with preload sounds "ON"
    • Notice the glitch kicking in when the time runs out and the positioned audio starts playing
    • Notice that the game works as intended again

    Observed Result

    See *Affected Browsers* section for browser specific information.

    Expected Result

    Everything should be loaded in, without any glitch just like in the "Equal Power" mode.

    Affected Browsers

    • NW.js: Full stop of the game for about 3 seconds until everything works again.
    • Firefox: Positioned audio loads in with a delay of about 2 seconds.
    • Internet Explorer: Works as intended, no joke!
    • Chrome: Same as NWjs.
    • Edge: -Not tested yet-
    • Opera: -Not tested yet-
    • Safari: -Not tested yet-

    Operating System and Service Pack

    Windows 7 with latest updates and up to date drivers.

    Construct 2 Version ID

    Newest release r233 Steam release. [Personal Edition]

    Additional maybe useful information:

    • NW.js version: v0.14.0
    • Checked C2 data with the Steam software data check system (0 Errors Found)
  • I think that this is a Chrome bug - I submitted (and just re-submitted) a bug report for it a few months ago. Please star the report if you experience the same bug in Chrome: here. In the interim there is a work-around - play a very quiet sound-at-position during a loader layout, where you won't notice any jank. The benefits of being reliant on browsers...

  • I think that this is a Chrome bug - I submitted (and just re-submitted) a bug report for it a few months ago. Please star the report if you experience the same bug in Chrome: here. In the interim there is a work-around - play a very quiet sound-at-position during a loader layout, where you won't notice any jank. The benefits of being reliant on browsers...

    Oh no, does that mean that we have to wait for them to fix it and wait for the NWjs team to update to the newest version too?

    I also thought about that workaround but I decided not to take any risk and run with "Equal Power" mode because you never know how other peoples PC's/Linux/OSX would react to this. What freezes for 3 seconds on my end might crash on theirs.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Closing as duplicate of https://www.scirra.com/forum/sound-issue_t180275

    tl;dr - it's a Chrome bug which is already fixed.

  • Closing as duplicate of https://www.scirra.com/forum/sound-issue_t180275

    tl;dr - it's a Chrome bug which is already fixed.

    Alright, thanks for the info.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread sticky
763 305,616
asikanddestroy's avatar
asikanddestroy
Unread hot topic
232 177,665
Tetriser's avatar
Tetriser
Unread hot topic
266 15,897
GameeApp's avatar
GameeApp