0 Favourites

Pathfinding bug?

  • Problem Description

    Pathfinding behaves weird after layout reset.

    It seems like it doesnt regenerate the pathfinding map before it starts to find a path and so on.

    In the attached capx you will see after the first ariving it always moves on the wrong path and i have no idea how to prevent this.

    Attach a Capx

    ____ Upload a Capx to this post ____

    Description of Capx

    ____ Concise description of what this CapX does ____

    Steps to Reproduce Bug

    • Step 1: open capx and run it
    • Step 2: see how it moves on the wright way the first time and then every time on the wrong way, its always the way it should have used on the layout before

    Operating System and Service Pack

    Win7

    Construct 2 Version ID

    173

  • ok, i found out when i use an "wait" action before "find path" it gets the wright path, but i cant estimate how long it should wait on different systems.

    is there a condition like "on regenerate finished" that im missing?

  • 'Regenerate obstacle map' takes 1 tick to update so won't be available unless you add a 'Wait'. Closing as won't fix, but I updated the manual entry to clarify this.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • ok, i found out when i use an "wait" action before "find path" it gets the wright path, but i cant estimate how long it should wait on different systems.

    is there a condition like "on regenerate finished" that im missing?

    Hi fldr! Sorry for offtopic here, but due to really strange forum rules I cant' send you private messages. Please send me message at my facebook page - facebook.com/pages/Gamestockgfx/121096871407696

    again sorry for offtopic guys:)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)