0 Favourites

Particle grow rate stops past a certain size

  • Problem Description

    Particles doesn't grow past a certain size, unless I resize the size of the browser.

    Attach a Capx

    [attachment=0:2hpc523b][/attachment:2hpc523b]

    Description of Capx

    I have a particle emitter that grows particle from 32px to 1000px as it fades out. No speed no gravity nothing else than grow rate.

    Steps to Reproduce Bug

    • Create particle emitter at size 32px
    • Make it grow to 1000px
    • No speed, no gravity.

    Observed Result

    It stops before expanding to a complete 1000px wide

    Expected Result

    It should grow out of the screen until it fades out completely.

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)
    • Internet Explorer: (YES)

    Operating System and Service Pack

    Windows 7

    Construct 2 Version ID

    r168

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Just linked a new file, the other wasn't the right one.

  • Setting grow rate to 1000 doesn't mean size will up to 1000px. It says "Rate the size changes over time, in pixels per second.". If timeout is 3, i expect it to size particles to 3000px (1000px * 3) not to 1000px. It seams everything works ok here. Nice effect by the way

  • Thanks for the reply! Even if I set the timeout to 10 seconds it won't grow to 1000px. It should have the time to grow that big?

  • I have tried that with 10 seconds timeout on circle shaped particle, it worked normally.

  • Can you link me your capx file? Does the particle goes out of the screen?

  • I have set only the circle shaped ("Particles") particle's timeout to 10.

    Yes, it goes out the screen.

  • It seems that in a certain resolution, it doesn't scale past a certain size... I tried it on different screens and it's certainly a problem because when I resize the browser it works. Can we scale a particle infinitely? Maybe not.

  • Can you link me the capx which you are talking about (set at certain resolution). May be i can help.

  • I think it might be a graphic card issue? Because it works fine on my laptop and not on my PC...

    The capx file you have is exactly what I have, the grow rate should infinitely expand a particle until the time you set out as a timeout. Even if I put 1000px as a grow rate and 20 seconds as TimeOut it still stops at a certain size. Not covering the entire screen.

    We tried on a bunch of different computers, and it's working for the others, not mine. So Construct people, if you read this I think we might have a real bug here

    this is my graphic card : Geforce GTX 780 / PCIe / SSE2 /

    OpenGL 4.4.0

  • Please be sure to follow the bug report guidelines: your .capx needed only one object and no events, but it was substantially more complicated, which made it take longer to investigate this.

    It looks like a bug in Chrome and Firefox's WebGL implementations (doesn't happen here in IE11, although you said it was affected, and it doesn't happen if you turn off WebGL in project properties). I've implemented a workaround for the next build.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)