0 Favourites

Node-Webkit, Unable to parse json?

  • Not sure if this should be posted at "How Do I" or here, so bear with me.

    Just finished making my game for Ludum Dare 27, when I ran into something rather unfortunate. The contest requires a windows version, and my node-webkit export version keeps messing up.

    I get a "Unable to parse Json" error, and the console tells me that there is a require that is undefined.

    I was using the last stable version, before updating to the beta in hopes it fixed my issue. No luck. I have also tried exporting both a minified and non-minified version.

    There is only a couple of hours left until the deadline, so while looking for an answer I am going to try reinstalling Construct 2. Would really suck to have worked the last 19 hours and not be able to show off my finished game.

    Link to .capx file (required!):

    dl.dropboxusercontent.com/u/124549522/ludeaire.capx

    Steps to reproduce:

    1. Load Game

    2. Export as node-webkit

    Observed result:

    Node-webkit error pops up saying "Unable to parse json."

    When looking in the console, the console says there is an uncaught reference error: require undefined.

    Expected result:

    Node-Webkit to load and begin playing the game

    Browsers affected:

    Browsers are unaffected

    Operating system & service pack:

    Windows 7 32bit, 6.1

    Construct 2 version:

        r139/r141

  • After about an hour or so teasing apart the .capx, I found the culprit!

    Oddly enough, it was the About section on the project tabs. I cleared the project information and my node-webkit export now works!

    Huzzah!

  • The quotation marks in the project description were breaking the node-webkit export. I see you got it sorted anyway.

  • Ahh okay I see, that's very good to know, thanks for the tip ramones

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Oops, we forgot to handle double quotes properly. Should be fixed in the next build.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
187 45,125
Yann's avatar
Yann
Unread hot topic
98 7,593
norum82's avatar
norum82
Unread hot topic
92 11,971
SgtConti's avatar
SgtConti