0 Favourites

NODE WEBKIT (multiplayer signalling error) - SKYPE!

  • Problem Description

    ____ A concise description of your problem here ____

    When exporting to NODE WEBKIT, sometimes the code won't connect to the SIGNALING SERVER (gives an OBJECT ERROR).

    This baffled me for a long time, but then I realized - the error only happens when SKYPE IS RUNNING.

    If you turn off SKYPE, it connects to the SIGNALING SERVER. This conflict with SKYPE only happens with a NODE WEBKIT export, not when running in a browser or when running in preview mode.

    Similarly, sometimes my NODE WEBKIT server would crash (object error). In fact, I couldn't get my multiplayer host to run for more than an hour without a crash. Some people on this forum suggest it's a MEMORY LEAK. I think not...

    I think it's a conflict with other programs. I traced my crashes to STEAM. I had it running in the background and when STEAM would go out and try to get an update from it's server, my HOST would get an error from the SIGNALING SERVER and crash.

    I'm guessing this is the same bug as SKYPE - some kind of conflict between applications.

    Attach a Capx

    ____ Upload a Capx to this post ____

    Description of Capx

    ____ Concise description of what this CapX does ____

    Steps to Reproduce Bug

    • Step 1
    • Step 2
    • Step 3 etc.

    Observed Result

    ____ What happens? ____

    Expected Result

    ____ What do you expect to happen? ____

    Affected Browsers

    • Chrome: (YES/NO)
    • FireFox: (YES/NO)
    • Internet Explorer: (YES/NO)

    Operating System and Service Pack

    ____ Your operating system and service pack ____

    Construct 2 Version ID

    ____ Exact version ID of Construct 2 you're using ____

  • Can't reproduce: multiplayer works just fine here in node-webkit even with Skype running. I assume there is an issue specific to your machine's network configuration. Try testing on other computers to see if the problem persists there.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I remember a time when I could not run some virtual servers with skype, I had to reconfigure skype so it does not use the same port, not sure if this is related though.

  • I just had this same problem. I went into Skype settings and disabled "uPnP" and it works now. Universal Plug and Play causes skype to automatically detect and setup ports in your router (something like that anyway) and it seems to conflict with Node Webkit. Anyway, hope this helps!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)