0 Favourites

IOS sound problems since iOS 9.2

  • Problem Description

    relaunching game after it is killed makes sound distorted on iOS 9.2

    Attach a Capx

    http://1drv.ms/1Zs4pYu

    Description of Capx

    plays sound when the button (there is only one) is clicked and after that on another sound is played in loop

    Steps to Reproduce Bug

    • Step 1 export as cordova from the capx
    • Step 2 create html5 project in intel xdk (source=(empty), use cordova plugin = no (setting it to yes makes no difference), game project = no)
    • Step 3 build as ios app
    • Step 4 install on iphone (i use iphone 6 with ios 9.2)
    • Step 5 start the app and touch the button. you will hearing sound and another sound in loop
    • Step 6 kill the app (not suspend but kill)
    • Step 7 restart the app
    • Step 8 touch the button again

    Observed Result

    now the sound is distorted

    Expected Result

    plays sound as it is

    Affected Browsers

    • Chrome: (YES/NO)
    • FireFox: (YES/NO)
    • Internet Explorer: (YES/NO) This only happens as app on iOS. Haven't been able to repro in Safari inside iphone.

    Operating System and Service Pack

    Win 10

    Construct 2 Version ID

    221

  • So I thought I had solved this same problem with my app but its not resolved.

    When I launch my iOS App the sound will sporadically have problems being distorted.

    Sometimes the background music will be fine and sometimes it grainy and choppy sounding.

    I am using iPhone 6 with iOS 9.2

  • Checkout this blog post: http://www.williammalone.com/posts/ios- ... ile-issue/

    When I tested the sound in that link using my iPhone the first "touchstart" audio is distorted but the other two are fine. Try that link out on an iPhone to reproduce the grainy audio.

    Looks like if you use "touchend" the audio plays fine.

  • I'm having the same issue but in addition to that, my app also crashes and when I restart the sound is distorted.

    Only on my iphone 6 ios9.2

  • I'm also having exactly the same problem with the sound becoming distorted. Can't seem to find any way to fix it...

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Mine is distorted, too.

  • As you know, i've got that problem on all devices with 9.2+.

    • iPhone 5,5s
    • iPhone 6,6+,6s,6s+

    The background music is distoret, but the jump sound etc. sounds normal.

  • I have the same problem with my background music specifically. Sometimes the sound effects also have issues.

    Checkout this blog post: http://www.williammalone.com/posts/ios- ... ile-issue/

    When I tested the sound in that link using my iPhone the first "touchstart" audio is distorted but the other two are fine. Try that link out on an iPhone to reproduce the grainy audio.

    Looks like if you use "touchend" the audio plays fine.

    I tried a lot of different ways in Construct 2 to fix this problem but none of them worked. I didn't see a way out of the box to fix this within Construct 2 without doing some manually coding.

  • I've found a fix, though it has a knock-on effect.

    The fix: Export for cordova like you usually would. Now go into the media folder and what you want to do is replace the existing audio with 48khz (sample rate) versions. How I did this was I fed all my audio through https://online-audio-converter.com/ (to change the sample rate you'll have to open up advanced settings).

    Now just build in the intel XDK, terminal or however you get it native on your iphone.

    The knock-on effect: I've found that on the first play or after the first play in some time, the music just turns into a faint but high pitched buzz. Upon rebooting the app it will all work normally, but as you would imagine this still isn't ideal.

    I have noticed that the "preload x" or "preloads complete" doesn't work on ios and I'm curious if this is something to do with it?

    Any ideas or suggestions would be great!

  • Ashley I am having the same exact issue on my games when loading from an iphone with iOS 9.2.1 installed. On first load, sound is completely distorted, but if the browser refreshed/reloaded all sounds plays properly. Is there a solution for this available in the upcoming release?

  • I've found a fix, though it has a knock-on effect.

    The fix: Export for cordova like you usually would. Now go into the media folder and what you want to do is replace the existing audio with 48khz (sample rate) versions. How I did this was I fed all my audio through https://online-audio-converter.com/ (to change the sample rate you'll have to open up advanced settings).

    Now just build in the intel XDK, terminal or however you get it native on your iphone.

    The knock-on effect: I've found that on the first play or after the first play in some time, the music just turns into a faint but high pitched buzz. Upon rebooting the app it will all work normally, but as you would imagine this still isn't ideal.

    I have noticed that the "preload x" or "preloads complete" doesn't work on ios and I'm curious if this is something to do with it?

    Any ideas or suggestions would be great!

    So changing the sample rate to 48000khz fixed the audio problem but I had no sound on the FIRST run but anytime after I ran it the sound was fine. Why would it require the app to open and close one time before the sound would work and is there a work around for this like preload which doesn't seem to do anything.

    Thanks for discovering this 0Hayes - I wish Scirra would look into it a little harder.

  • [quote:2hwzm8bd]So changing the sample rate to 48000khz fixed the audio problem but I had no sound on the FIRST run but anytime after I ran it the sound was fine. Why would it require the app to open and close one time before the sound would work and is there a work around for this like preload which doesn't seem to do anything.

    Thanks for discovering this 0Hayes - I wish Scirra would look into it a little harder.

    @mars1985 Yeah, issue I had. If you turn the volume all the way up on your phone, you should notice the buzzing. I'm going to try some different sample rates and see if the effect is any different. That way I'll be able to work out if it's because they all need to be the same sample rate, or if it's because they all need to be 48000khz.

    Other than that, I'm not sure what else to try. Any suggestions or a word from Ashley would be fantastic!

  • I'm going to try some different sample rates and see if the effect is any different. That way I'll be able to work out if it's because they all need to be the same sample rate, or if it's because they all need to be 48000khz.

    Tried as low as 8000khz and the old bug (distortion) persists. It does seem like the 48000khz option is the way forward.

    Again, if anybody else is working on a fix please let us know what you've tried so were not all attempting the same things.

  • I could not reproduce this on an iPad Air 2 running iOS 9.2.1, after building the Cordova export with PhoneGap Build. Could somebody else affected try PhoneGap Build as well? Perhaps it's something about the Intel XDK that is causing this.

  • Ashley cheers for looking into it! Looks like it doesn't effect the iPad Air 2 (same response from one of my testers). I have however only tested on iPhone 6 myself. I'm not using the Intel XDK myself, never been a fan. I'm using the Cordova CLI (6).

    I'll give phonegap a whirl my side on Monday but if anybody else has chance before then that would be great!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
115 23,724
justifun's avatar
justifun
Unread hot topic
99 8,957
gumshoe2029's avatar
gumshoe2029
Topic
21 1,964
BarthSoftware's avatar
BarthSoftware