0 Favourites

Importing a Sprite Strip makes Construct freeze

  • Problem Description

    ____ I was trying to import an animation from a spritesheet/sprite strip. It made Construct freeze for like a good ten minutes before finally bringing up the dialogue to let me set rows and columns. So, thinking maybe my project was too big or the sprite sheet image was too big, I started a new project and tried again with a smaller image. Still froze for a good couple of minutes. The second image I tried was only 64x64 pixels. I timed it, and it literally took 2 MINUTES AND 35 SECONDS to import. There's no reason that should have been so slow. Importing the image as a frame or opening the image works fine and takes no time at all, even if the image is very large.

    I used to be able to import sprite sheets just fine, so it is definitely a recent development.

    Attach a Capx

    ____ No Capx, it did this on a new project ____

    Description of Capx

    ____ It's any project. ____

    Steps to Reproduce Bug

    • Open a project or start a new one.
    • Import an image as a sprite sheet
    • Wait???

    Observed Result

    ____ I wait for a really long time and sometimes just have to task manager shutdown Construct because it's sat there for like ten minutes frozen____

    Expected Result

    ____ A 64x64 image should import in no time, even as a sprite strip. ____

    Affected Browsers

    • Chrome: N/A
    • FireFox: N/A
    • Internet Explorer: N/A

    Operating System and Service Pack

    ____ Windows 7 ____

    Construct 2 Version ID

    ____ Version 168 ____

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I've seen this too!

    As I recall, I had a sprite that had already had a frame added to it manually, and then, almost without fail, if I tried importing a sprite strip to that sprite, freeze/crash.

    Glad I'm not alone/crazy

    -Remy

  • I've seen this too!

    As I recall, I had a sprite that had already had a frame added to it manually, and then, almost without fail, if I tried importing a sprite strip to that sprite, freeze/crash.

    Glad I'm not alone/crazy

    -Remy

    Oh, and if I simply imported a sprite strip from the get to (no additional frames added) it would always work.

  • I tried using both methods discussed and C2 didn't crash for me.

    Are there any steps missing?

    Is this with a particular sprite strip or any strip?

    What are the strip dimensions?

    It may help to provide a sample that causes a crash, and maybe more instructions as at the moment, it appears to be perfectly ok for me?

  • I'm pretty convinced at this point that my computer is just crap and I need a new one.

  • Please include the actual image you imported as well as the import settings when reporting bugs so we can reproduce the problem. The time it takes depends heavily on the horizontal/vertical cell count you enter. I just tried importing a random image file as a sprite sheet, it defaulted to 1x1, and imported a single frame instantly.

  • I have had this happen to me quite a few times recently. It is unpredictable and very hard to reproduce.

    From what I can tell the window for splicing the sprite strip is still there, just not showing.

    most times the splice menu will show up if I let it sit long enough.

    Like I said it is all rather random, and I have had it happen in multiple projects. Restarting construct 2 doesn't seem to affect it, after a little while works like normal again.

  • Closing since no reliable steps to reproduce provided since April. We cannot investigate the problem without that. Please file a new report if you can find a way to reproduce it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)