0 Favourites

[Gave Up] IAP Amazon/Google Play/Chrome Web not working

  • Problem Description

    The IAP for Google Play and Chrome Web store and Amazon packaged web app are not working as they should (or as I understand they should). The IAP returns false for 'is store available' in the Chrome Web store and Amazon web app and 'Has Product' is always returning false on Google Play. I've tried with iap testing true and false.

    Attach a Capx

    http://www.datainterlock.com/ConstructBugs/iapTest.capx

    Description of Capx

    Simply attempts to connect to the IAP store and retrieve information and 'has product' status. A button is to allow the product to be purchased and a text object displays the results of the IAP connection.

    .apx was compiled as webview using XDK.

    Observed Result

    Amazon Mobile Web

    • The result for 'is store available' = false.

    Chrome Web Store

    • The result for 'is store available' = false.

    Google Play prior to purchase

    • The result for 'is store available' = true.
    • On store listing success - all the the IAP fields return nothing.
    • Has product returns false.

    Google Play after purchase

    • The result for 'is store available' = true.
    • On store listing success - iap.productName and iap.productPrice will have the correct product name and price. iap.appName and iap.appPrice return nothing.
    • Has product returns false.

    Expected Result

    Amazon store should be available.

    Chrome Web store should be avaialble.

    IAP should return true for hasProduct if the product has been purchased.

    Operating System and Service Pack

    Win 10 / Android Lolipop

    Construct 2 Version ID

    r219 / 64

  • You don't see an issue with "is store available" running under on start of layout?

  • Ummm no, why should it be? It's obviously getting the response, at least in Google Play. If I want to know if the app is paid for before I show my menu, it seems pretty logical that I should put it in the startup. And if I'm waiting for listing success it shouldn't matter.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • On start of layout only runs one tick, and you have no guarantee that your request will get there and back, let alone register in that time.

  • Well, it should only take one tick. It's not like I should need to repeat it every tick. Is store available triggers an event. And it's not like you can make 'has product' wait for a response. It has no event to trigger.

    As I said, it's finding the store (Google Play) and getting the listing. Has product is simply coming back false every time.

    I don't get what you're saying. That this all has to be delayed somehow?

    (This is with the product being purchased)

  • I realize it's the holidays and Ashley and the crew probably aren't around, but I've now been 3 months on a project that was finished in 2 weeks. But I can't sell the thing because I can't get IAP to work. So here I sit, regretting ever buying C2.

    Could I get some answer as to whether this is a bug or if I'm doing something wrong (and what, not obscure guesses.)

  • And it's not working as an Amazon moble web app. I've uploaded it to my server, loaded it into the Amazon Mobile Web App tester and I'm getting Store Not Available.

    And apparently store available for google play will return true on start of layout. But store listing may fail several times before it finally comes back true.

    I've tried setting IAP testing to both true and false with the same results.

  • Ashley, could I please get some response to this? I even sent an e-mail to support several days ago with no reply. Not being able to sell my product has stopped all work and makes me really, really regret buying C2. PLEASE.

  • This was posted while most of us were out on holidays over the festive season, and we normally ask for a few weeks to get round to reviewing reports. Please be patient! I should be reviewing more bug reports this week.

  • Thank you. I'm trying. Been trying to figure this out for over a month now. https://www.scirra.com/forum/viewtopic.php?t=164992

  • Saw in the patch notes the update to IAP so I upgraded to r220 beta and tried again.

    • Running on local host - Store found (boggle if I read the iap js correct it's assuming Chrome Web) - Store Listing Failed. In r219 I got Store not found.
    • Exported to Amazon and ran it on their web app tester - Store not found.
    • Exported to Chrome Web and uploaded to the store - Store not found.
    • Google Play - Unchanged. Finds the store, gets the product, does a proper purchase and then comes back with a false 'has product'.
  • So umm... I'm now over 2 months and still have no answer as to whether this is a bug or I'm doing it wrong.

  • Over 3 months now since my first post on this and I'm no closer to a solution now than I was then. I fully realize that Ashley is the proverbial one-legged man in an ass-kicking contest but, since I'm unable to sell what I've created, I'm still waiting for an answer when I could have been clicking on the upgrade button.

  • Over 3 months now since my first post on this and I'm no closer to a solution now than I was then. I fully realize that Ashley is the proverbial one-legged man in an ass-kicking contest but, since I'm unable to sell what I've created, I'm still waiting for an answer when I could have been clicking on the upgrade button.

    This is web technology, you have to be patient and wait until it gets fixed.

    Problems like this with plugins not working will always happen in future too because there will always be some changes applied,

    that I guess somehow help (?) to be more efficient and better.

  • Actually , no it shouldn't be that way. This is an official plug. It should work as stated, or at least have an official statement why it's currently not working.

    The problem is that he has nothing to tell that he is doing something wrong, or if it's broken.

    The plug has very little documentation, and no official examples.

    This isn't one of those novice expectations like one click deploy, or unlimited ram.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)