0 Favourites

Function Object disappeared

  • Problem Description

    Function object is not in the object list anymore!

    Attach a Capx

    Capx is attached now. I tested it again on an other project and I saw that function is in the list.

    Description of Capx

    Games, with sprites and timers.

    Steps to Reproduce Bug

    • Open the project in Construct 2
    • Right click on layout or in objects list and click on add new object
    • Look for function object - There is none.

    Observed Result

    In the latest version none of those functions take effect.

    In the previous version they take effect but I can not add any new ones since I can not see it in the list.

    Expected Result

    To see the function object in the object list and also use it properly in the new version.

    Affected Browsers

      Not a browser problem

    Operating System and Service Pack

    Windows 7 SP 1

    Construct 2 Version ID

    Construct 2 release 139 (64-bit) There is no Function in the list but existing ones works.

    Construct 2 release 178 (64-bit) There is no Function in the list and existing ones dont work.

    Cheers

  • Ok I am taking back the 139 related one. I was not aware of the function object is something you can add only once.

    It is clear now. But still the project I developed on 139 release is not working properly on 178 release. Especially changing the directions are not.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Release 139 is one year old, so there may be some breaking changes that occured even though scirra does a lot of effort to reduce them to the bare bone.

    I would suggest trying it with some releases between 139 and 178, so you can see around which release it stopped working

    Then using the releases notes you should be able to see the breaking changes related to it maybe.

    https://www.scirra.com/construct2/releases

    Edit: if you can try r158 and r152, if it does not work in r158, but works in r152, it may be related to the fact the animation speed expression is now always positive

  • Closing, no .capx attached, please follow the bug report guidelines. Also it's by design that if the Function object is already in the project, it's hidden from the new object dialog.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)