0 Favourites

Error loading project on Windows 8 tablet

  • Error loading project on Windows 8 tablet

    I have a number of project on my desktop that I copied over to my Windows 8 tablet in order to work with them on the go. Upon opening any of the projects on my tablet I'm getting the following error saying there was an issue with the XML. See below picture:

    If I create new capx on the tablet and try to open it everything works as intended.

    A few other things to note. Since the tablet has no storage space, Construct2 is installed on an SD card being used as an extra drive; the C2 projects are also stored on that secondary drive. I noticed if I open a capx by double clicking on it the license file is not detected and it starts in free mode. If instead, I navigate to the install directory and open the Construct2 exe directly everything functions as intended. Neither method or administrator mode lets me open the capx files from my desktop though.

    Attach a Capx

    I don't use capx files since I use version control software. I've uploaded a zip of the project

    Description of Capx

    The capx does not open.

    Steps to Reproduce Bug

    • Click on capx to open/Open Construct2
    • Observe error.

    Observed Result

    The attached error is desplayed

    Expected Result

    The capx opens fine.

    Affected Browsers

      N/A

    Operating System and Service Pack

    Windows 8.1 32bit (64bit processor)

    This is the exact tablet I'm trying to open the capx on: http://www.microcenter.com/product/439773/TW700_Tablet_-_Black

    Construct 2 Version ID

    r195

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • This is a really old project built with r138.2 (july 2013) and is corrupt.

    There are a couple of backup files, and removing the .backup1 extension (as stated in the manual) allows you to open the backup (see attached).

    That may be the best you will get from this.

  • Oh, I have this all backed up in source control so it was never about losing data. And yeah, this was an old project I abandoned so I didn't mind sharing it.

    This issue still happens with my current project on r195, I just don't want to share it publicly. If Ashley has an email I can send it to I'd be happy to.

  • Ashley will say that unless you can give a simplified .capx with exact procedure for creating the issue then there will be nothing he can do.

    This is just corruption and can happen for numerous, non C2 related reasons.

  • Ok, I'll do that! This is important to me since I'll finally be able to work on my C2 projects on the go! Thanks for the pointers.

  • Closing as this is probably a corrupt project and not a C2 bug. We can help recover files if you send them to support email, but it's not always possible. You should have backups enabled and simply revert to an earlier backup.

  • No worries. I have everything in version control (git specifically) so it was never about losing a project, data or anything.

    The issue was all my projects work on my PC but don't work on my Win8 tablet, I thought something else was wrong so I never considered project corruption... I suppose it could happen when transferring over the USB thumbstick?

    Regardless I'll see if I can produce a minimal capx and more details next time.

    Thanks!!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)