0 Favourites

CAR BEHAVIOUR/COLLION/FRAMERATE BUG

  • Hi guys...

    I've got a severe issue after finally getting getting into and out of a car working properly, but after this it had the consequence of causing all sorts of anomalies with the driving behaviour.. for instance some of the things that have started happening are.

    Stuttering movement

    Sometimes very very slow

    "Catches" invisible edges

    Poor smoothness which seems like low-FPS

    Previously the car driving mechanics felt very nice and smooth... now it is unplayable and unbroken.

    Here is a video of the issue -

    VIDEO

    https://www.youtube.com/watch?v=YX8a-kUeYrQ

    .CAPX FILE

    https://drive.google.com/file/d/0B-fSfDFgkZLIY0hJX2twNXZCS00/view?usp=sharing

    Steps to Reproduce Bug

      Get in car Drive

    Observed Result

    Stuttering movement

    Sometimes very very slow

    "Catches" invisible edges

    Poor smoothness which seems like low-FPS

    Expected Result

    Normal smooth driving and framerate/performance

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)
    • Internet Explorer: (YES)

    Operating System and Service Pack

    Windows 7 64bit - Service Pack 1

    Construct 2 Version ID

    212.2 64bit

  • Why have you got 10 Tilemaps on one Layer? The draw calls are using like 98% CPU - it's madness.

  • Why have you got 10 Tilemaps on one Layer? The draw calls are using like 98% CPU - it's madness.

    Ah I see, do you think this could be contributing to the issue? Although the driving and performance was absolutely fine with the exact same amount of tilemaps, before I managed to get getting out of the car working properly.

    I searched in the past whether it was better to use 1 large tilemap or many small individual ones but couldn't find any answers or tips.

    Each of my background textures is a single tilemap (varying from 32x32 to 64x128 etc...)

    Would it be advised to compile them all into 1 large tilemap?

    Thanks for your reply, first I've gotten from anyone regarding this issue.

    EDIT: Also, part of the reason I used many small individual tilemaps instead of 1 large one was that when I first installed Construct 2, I attempted to used a single large .JPG images as my background (with basic stuff like the roads/pavements/grass etc..) but when I tried to run it there was nothing but a black screen, and I read that Construct 2 does not allow images over a certain size in pixels... (this was 9000x9000 pixels).

  • What I can see - correct me if I'm wrong - is that only one of the Tilemaps has a behavior (Solid) attached.

    If so, then you could just use 2 Tilemaps - one for the general background and the other on a different Layer utilising the Solid behavior.

    It would make your life easier, and the C2 engine's task much simpler.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Thanks, none of the tile maps have a solid, but yes 1 tilemap (water) has a "bullet" behaviour added to emulate flowing water, which perhaps would be more CPU friendly to animate as a sprite, although it is very large, about 5000x2000 pixels area....

    Although the car's weird behavior and performance slowdown was not happening before I tweaked the event file quite a lot in an attempt to be able to get my player to leave the vehicle (before when I left the vehicle I would appear where I entered, IE: the player was not pinning to the car correctly upon entering).

    Do you think this is unrelated to the tilemap overload? Thanks (I will definitely consolidate my tilemaps into 1 or 2 larger ones as well!)

    EDIT: OOPS! Just realised the .capx file I uploaded has the window screen size to maximum so I could screenshot the idea map to make a separate shadow map layer, I will reupload with the window size at normal! Sorry about that!

  • What I can see - correct me if I'm wrong - is that only one of the Tilemaps has a behavior (Solid) attached.

    If so, then you could just use 2 Tilemaps - one for the general background and the other on a different Layer utilising the Solid behavior.

    It would make your life easier, and the C2 engine's task much simpler.

    NEW .CAPX - SORRY ABOUT THAT!

    drive.google.com/file/d/0B-fSfD ... sp=sharing

    Window Size was set to 9kx9k for a different reason, this would explain why it was using 98% CPU or so.

  • Runs perfectly smoothly on my (high-end) dev machine. If you have performance issues, look up performance tips in the manual. If you have other issues, please see the bug report requirements regarding submitting a minimal .capx.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
90 77,102
leonhard's avatar
leonhard
Unread hot topic
0 Favourites
random bugs and suggestions
90 4,517
Tom's avatar
Tom Construct Team Founder
Unread hot topic
71 8,592
massivemonster's avatar
massivemonster