0 Favourites

Can't open package.appxmanifest in VS2015

  • Problem Description

    ____ I export a game with Construct2 (release 212.2) to Windows 10, I open it with VS Community 2015, and I can't open the package.appxmanifest to edit the pictures, etc as I could do for win 8.1 ____

    Attach a Capx

    ____ https://www.dropbox.com/s/vojr20dih5kz4 ... .capx?dl=0 ____

    Description of Capx

    ____ a game with background and 2 sprites that can be moved ____

    Steps to Reproduce Bug

    export game for windows 10

    open .snl with VS community 2015

    try to open the package.appxmanifest

    Observed Result

    ____ .appxmanifest wont open, nothing at all happens, no error other than "This item does not support previewing" at the bottom of the empty viewing panel ____

    Expected Result

    ____ .appxmanifest should open ____

    Affected Browsers

    • has nothing to do with browers Operating System and Service Pack ____ windows 8.1 ____ Construct 2 Version ID ____ 212.2 ____
  • I can't reproduce here: once exported for Windows 10, it opens in VS2015 just fine. Are you sure you installed the Windows Store component in the VS2015 installer? It might be worth reinstalling and double-checking which components are enabled.

  • Um, is the Windows 8 part possibly part of the problem here?

  • That's a good point - you can only build Windows 10 Store apps with Windows 10. If you have Windows 8.1 I don't think you can build Windows 10 apps. That's a limitation in Visual Studio itself.

  • Paula22 é BR ?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I can't reproduce here: once exported for Windows 10, it opens in VS2015 just fine. Are you sure you installed the Windows Store component in the VS2015 installer? It might be worth reinstalling and double-checking which components are enabled.

    Ashley, you will look at the problem of multiplayer?

  • Ashley, you will look at the problem of multiplayer?

    I don't believe this is related to this bug report at all. Perhaps you should start a new thread in a different section, but note Edge does not support multiplayer yet.

  • I guess it can be because of the Windows 8.1 OS yes. So I tried the following:

    1- I exported this game (lets call it game1) for Windows 8.1 Universal in Construct2 r212, and then I opened it with my VS Community 2013: Then the package.appxmanifest wont open and in this case it gives me an error that says : "Unable to load manifest designer"

    2- So I tried downgrading Construct 2 to an older version (r206): I couldn't open my game1 in this older version because it was created with a newer version of Construct2.

    3-Then I tried an older game I have=game2, exporting it with Construct2 r206 for Windows 8.1, I opened it with the same VS Community 2013, and the package.appxmanifest opens perfectly well.

    4- I upgraded my Construct2 again, to version 212.2, then I again exported old game2, and again in this case the package.appxmanifest opens without problems.

    So (correct me if I'm wrong) it seems to be that for whatever reason there is an incompatibility between games created with Construct r212 and both VS 2013 and VS 2015

  • I guess it can be because of the Windows 8.1 OS yes. So I tried the following:

    1- I exported this game (lets call it game1) for Windows 8.1 Universal in Construct2 r212, and then I opened it with my VS Community 2013: Then the package.appxmanifest wont open and in this case it gives me an error that says : "Unable to load manifest designer"

    2- So I tried downgrading Construct 2 to an older version (r206): I couldn't open my game1 in this older version because it was created with a newer version of Construct2.

    3-Then I tried an older game I have=game2, exporting it with Construct2 r206 for Windows 8.1, I opened it with the same VS Community 2013, and the package.appxmanifest opens perfectly well.

    4- I upgraded my Construct2 again, to version 212.2, then I again exported old game2, and again in this case the package.appxmanifest opens without problems.

    So (correct me if I'm wrong) it seems to be that for whatever reason there is an incompatibility between games created with Construct r212 and both VS 2013 and VS 2015

    Paula22 é Brasileiro

  • Hello Ashley, having problems with this myself.

    The project loads fine in VS2015, but I can't edit the manifest or run the project in VS.

    (Please note: the windows universal app packages are installed in VS)

    Here is what I am seeing:

    Try to load the manifest to edit it:

    This error is displayed on screen:

    If I try to run the project this error is displayed at bottom of screen"

    Error	APPX0501	Validation error. error C00CE169: App manifest validation error: The app manifest must be valid as per schema: Line 24, Column 18, Reason: '' violates minLength constraint of '1'. The attribute 'Id' with value '' failed to parse.	Mbv2test	I:\Games_2D\Games\MBV3\Release Build\bin\Debug\AppxManifest.xml	1[/code:tshv251y]
    
    [b]Also [/b]C2 does not create the html files for About, Support, or Privacy pages.
    
    Am I missing something here?
    
    Thanks
  • Change the Id to a string.

  • michael - are you on Windows 10 or Windows 8.1? I think VS2015 requires Windows 10 to be able to make Windows 10 apps (not too surprising there). Also the XML validation thing looks like maybe you just need to type in an ID in project properties? If so then the editor needs to prompt for that.

  • Ashley, I wrote this before but I guess you didn't see it: when I export the game created in Construct 212.2 for Windows 8.1, and then try to edit the manifest in VS 2013, I get error too. This has nothing to do with Windows 10.

  • michael - are you on Windows 10 or Windows 8.1? I think VS2015 requires Windows 10 to be able to make Windows 10 apps (not too surprising there). Also the XML validation thing looks like maybe you just need to type in an ID in project properties? If so then the editor needs to prompt for that.

    Ashley, thanks for reply. Yes I am running Windows 10 Pro.

    With regard to project ID, do you mean in C2?

    I will check it out in the morning....

  • Hi Ashley

    That's a good point - you can only build Windows 10 Store apps with Windows 10. If you have Windows 8.1 I don't think you can build Windows 10 apps. That's a limitation in Visual Studio itself.

    From Microsoft VS2015 download page:

    "Provides the core tools for building compelling, innovative apps for Universal Windows Platform. Windows 10 is required."

    With regard to project ID, do you mean in C2?

    I will check it out in the morning....

    Added an ID in C2 and all works now, (never needed this before, probably required by Window Phone i guess).

    However still wondering about the lack of About, Support, and Privacey pages.

    Been out of the windows app loop for a while, so will go do some checking. Any info would be appreciated...

    Thanks...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)